libdbus-c++_0.9.0.bb 1.3 KB

123456789101112131415161718192021222324252627282930
  1. SUMMARY = "DBus-C++ Library"
  2. DESCRIPTION = "DBus-c++ attempts to provide a C++ API for D-BUS. The library has a glib and an Ecore mainloop integration. It also offers an optional own main loop."
  3. HOMEPAGE = "http://dbus-cplusplus.sourceforge.net"
  4. SECTION = "base"
  5. LICENSE = "LGPLv2.1"
  6. LIC_FILES_CHKSUM = "file://COPYING;md5=fbc093901857fcd118f065f900982c24"
  7. DEPENDS = "dbus expat glib-2.0 libpcre"
  8. SRC_URI = "${SOURCEFORGE_MIRROR}/project/dbus-cplusplus/dbus-c++/${PV}/${BP}.tar.gz \
  9. file://fix-missing-unistd.h-include.patch \
  10. file://remove-CXX_FOR_BUILD-stuff.patch \
  11. file://0001-src-eventloop.cpp-use-portable-method-for-initializi.patch \
  12. file://0002-tools-generate_proxy.cpp-avoid-possibly-undefined-ui.patch \
  13. file://0003-Fixed-undefined-ssize_t-for-clang-3.8.0-on-FreeBSD.patch \
  14. file://0004-use-POSIX-poll.h-instead-of-sys-poll.h.patch \
  15. file://0001-pipe.c-Use-a-string-instead-of-char.patch \
  16. "
  17. SRC_URI[md5sum] = "e752116f523fa88ef041e63d3dee4de2"
  18. SRC_URI[sha256sum] = "bc11ac297b3cb010be904c72789695543ee3fdf3d75cdc8225fd371385af4e61"
  19. inherit autotools pkgconfig
  20. EXTRA_OECONF = "--disable-ecore --disable-examples --disable-tests"
  21. LDFLAGS += "-pthread"
  22. PACKAGE_BEFORE_PN = "${PN}-tools"
  23. FILES_${PN}-tools = "${bindir}"
  24. BBCLASSEXTEND = "native"