wvstreams_4.6.1.bb 2.3 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758
  1. HOMEPAGE = "http://alumnit.ca/wiki/index.php?page=WvStreams"
  2. SUMMARY = "WvStreams is a network programming library in C++"
  3. LICENSE = "LGPLv2"
  4. LIC_FILES_CHKSUM = "file://LICENSE;md5=55ca817ccb7d5b5b66355690e9abc605"
  5. DEPENDS = "zlib openssl (>= 0.9.8) dbus readline"
  6. DEPENDS_append_libc-musl = " argp-standalone libexecinfo"
  7. SRC_URI = "https://storage.googleapis.com/google-code-archive-downloads/v2/code.google.com/${BPN}/${BP}.tar.gz \
  8. file://04_signed_request.diff \
  9. file://05_gcc.diff \
  10. file://06_gcc-4.7.diff \
  11. file://07_buildflags.diff \
  12. file://gcc-6.patch \
  13. file://argp.patch \
  14. file://0001-Check-for-limits.h-during-configure.patch \
  15. file://0003-wvtask-Check-for-HAVE_LIBC_STACK_END-only-on-glibc-s.patch \
  16. file://0004-wvcrash-Replace-use-of-basename-API.patch \
  17. file://0005-check-for-libexecinfo-during-configure.patch \
  18. file://0001-build-fix-parallel-make.patch \
  19. file://0002-wvrules.mk-Use-_DEFAULT_SOURCE.patch \
  20. file://openssl-buildfix.patch \
  21. file://0001-Forward-port-to-OpenSSL-1.1.x.patch \
  22. file://0001-Fix-narrowing-conversion-error.patch \
  23. "
  24. SRC_URI[md5sum] = "2760dac31a43d452a19a3147bfde571c"
  25. SRC_URI[sha256sum] = "8403f5fbf83aa9ac0c6ce15d97fd85607488152aa84e007b7d0621b8ebc07633"
  26. COMPATIBLE_HOST_libc-musl = "null"
  27. inherit autotools-brokensep pkgconfig
  28. TARGET_CFLAGS_append = " -fno-tree-dce -fno-optimize-sibling-calls"
  29. LDFLAGS_append = " -Wl,-rpath-link,${CROSS_DIR}/${TARGET_SYS}/lib"
  30. EXTRA_OECONF = " --without-tcl --without-qt --without-pam --without-valgrind"
  31. PACKAGES_prepend = "libuniconf "
  32. PACKAGES_prepend = "uniconfd "
  33. PACKAGES_prepend = "libwvstreams-base "
  34. PACKAGES_prepend = "libwvstreams-extras "
  35. PACKAGES_prepend = "${PN}-valgrind "
  36. RPROVIDES_${PN}-dbg += "libuniconf-dbg uniconfd-dbg libwvstreams-base-dbg libwvstreams-extras-dbg"
  37. FILES_libuniconf = "${libdir}/libuniconf.so.*"
  38. FILES_uniconfd = "${sbindir}/uniconfd ${sysconfdir}/uniconf.conf ${localstatedir}/uniconf"
  39. FILES_libwvstreams-base = "${libdir}/libwvutils.so.*"
  40. FILES_libwvstreams-extras = "${libdir}/libwvbase.so.* ${libdir}/libwvstreams.so.*"
  41. FILES_${PN}-valgrind = "${libdir}/valgrind/wvstreams.supp"
  42. RDEPENDS_${PN} += "perl"