mosh_1.3.2.bb 2.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748
  1. # NOTE: mosh-server requires a UTF-8 locale, but there's no way to add
  2. # an explicit dependency for this so you need to ensure this is in your
  3. # image yourself when you install mosh-server.
  4. SUMMARY = "Remote shell supporting roaming and high-latency connections"
  5. DESCRIPTION = "Remote terminal application that allows roaming, supports \
  6. intermittent connectivity, and provides intelligent local echo and line \
  7. editing of user keystrokes. Mosh is a replacement for SSH. It's more \
  8. robust and responsive, especially over Wi-Fi, cellular, and \
  9. long-distance links."
  10. HOMEPAGE = "http://mosh.mit.edu"
  11. LICENSE = "GPLv3+"
  12. LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
  13. DEPENDS = "protobuf-native protobuf ncurses zlib libio-pty-perl openssl libutempter"
  14. SRC_URI = "http://mosh.mit.edu/mosh-${PV}.tar.gz \
  15. file://0001-Fix-building-with-libc.patch \
  16. "
  17. SRC_URI[md5sum] = "5122f4d2b973ab7c38dcdac8c35cb61e"
  18. SRC_URI[sha256sum] = "da600573dfa827d88ce114e0fed30210689381bbdcff543c931e4d6a2e851216"
  19. inherit autotools pkgconfig
  20. PACKAGE_BEFORE_PN += "${PN}-server"
  21. FILES_${PN}-server = "${bindir}/mosh-server"
  22. NEEDED_PERL_MODULES = "\
  23. perl-module-socket \
  24. perl-module-getopt-long \
  25. perl-module-errno \
  26. perl-module-io-socket-inet \
  27. perl-module-posix \
  28. "
  29. # mosh uses SSH to authenticate and the client uses OpenSSH-specific features
  30. RDEPENDS_${PN} += "openssh-ssh ${NEEDED_PERL_MODULES}"
  31. # The server seemed not to work with dropbear either
  32. RDEPENDS_${PN}-server += "openssh-sshd ${NEEDED_PERL_MODULES}"
  33. # Fails to build with thumb-1 (qemuarm)
  34. #| {standard input}: Assembler messages:
  35. #| {standard input}:2100: Error: instruction not supported in Thumb16 mode -- `adds r4,r4,r4'
  36. #| {standard input}:2101: Error: instruction not supported in Thumb16 mode -- `adcs r5,r5,r5'
  37. #| {standard input}:2102: Error: instruction not supported in Thumb16 mode -- `adcs r6,r6,r6'
  38. #| {standard input}:2103: Error: instruction not supported in Thumb16 mode -- `adcs r7,r7,r7'
  39. #| {standard input}:2104: Error: selected processor does not support Thumb mode `it cs'
  40. ARM_INSTRUCTION_SET = "arm"