gammu_1.32.0.bb 2.3 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465666768
  1. SUMMARY = "GNU All Mobile Managment Utilities"
  2. SECTION = "console/network"
  3. DEPENDS = "cmake-native virtual/libiconv libdbi mysql5 glib-2.0 udev libgudev unixodbc"
  4. LICENSE = "GPLv2"
  5. LIC_FILES_CHKSUM = "file://COPYING;md5=a17cb0a873d252440acfdf9b3d0e7fbf"
  6. HOMEPAGE = "http://www.gammu.org/"
  7. SRC_URI = "${SOURCEFORGE_MIRROR}/${BPN}/${BPN}/${PV}/${BP}.tar.bz2 \
  8. file://gammurc \
  9. file://gammu-smsdrc \
  10. "
  11. SRC_URI[md5sum] = "8ea16c6b3cc48097a8e62311fe0e25b9"
  12. SRC_URI[sha256sum] = "de67caa102aa4c8fbed5300e5a0262e40411c4cc79f4379a8d34eed797968fc3"
  13. inherit distutils3 cmake gettext
  14. do_install_append() {
  15. # these files seem to only be used by symbian and trigger QA warnings
  16. rm -rf ${D}/usr/share/gammu
  17. #install default configuration files
  18. install -d ${D}${sysconfdir}
  19. install -m 0644 ${WORKDIR}/gammurc ${D}${sysconfdir}/gammurc
  20. install -m 0644 ${WORKDIR}/gammu-smsdrc ${D}${sysconfdir}/gammu-smsdrc
  21. }
  22. EXTRA_OECONF = " \
  23. --enable-shared \
  24. --enable-backup \
  25. --enable-protection \
  26. "
  27. EXTRA_OECMAKE = " \
  28. -DWITH_CURL=OFF \
  29. -DWITH_BLUETOOTH=OFF \
  30. -DWITH_NOKIA_SUPPORT=OFF \
  31. -DWITH_IRDA=OFF \
  32. -DWITH_PYTHON=OFF \
  33. -DWITH_MySQL=ON \
  34. -DWITH_Postgres=OFF \
  35. "
  36. PACKAGES =+ "${PN}-smsd libgammu libgsmsd python-${PN}"
  37. FILES_${PN} = "${bindir}/gammu ${bindir}/jadmaker ${sysconfdir}/bash_completion.d/gammu \
  38. ${bindir}/gammu-detect ${sysconfdir}/gammurc"
  39. CONFFILES_${PN} = "${sysconfdir}/gammurc"
  40. FILES_${PN}-smsd = "${bindir}/gammu-smsd* ${sysconfdir}/gammu-smsdrc"
  41. CONFFILES_${PN}-smsd = "${sysconfdir}/gammu-smsdrc"
  42. FILES_${PN}-dev += "${bindir}/gammu-config ${libdir}/*.so"
  43. FILES_${PN}-dbg += "${bindir}/.debug ${libdir}/.debug ${PYTHON_SITEPACKAGES_DIR}/gammu/.debug"
  44. FILES_libgammu = "${libdir}/libGammu.so.*"
  45. FILES_libgsmsd = "${libdir}/libgsmsd.so.*"
  46. FILES_python-${PN} = "${PYTHON_SITEPACKAGES_DIR}/gammu/*.??"
  47. RDEPENDS_${PN} += "bash"
  48. RDEPENDS_${PN}-dev += "bash"
  49. # Fails to build with thumb-1 (qemuarm)
  50. # gammu-1.32.0/libgammu/service/sms/gsmems.c:542:1: internal compiler error: in patch_jump_insn, at cfgrtl.c:1275
  51. # | }
  52. # | ^
  53. # | Please submit a full bug report,
  54. # | with preprocessed source if appropriate.
  55. # | See <http://gcc.gnu.org/bugs.html> for instructions.
  56. # | make[2]: *** [libgammu/CMakeFiles/libGammu.dir/service/sms/gsmems.o] Error 1
  57. # | make[2]: *** Waiting for unfinished jobs....
  58. ARM_INSTRUCTION_SET = "arm"