tinymembench_git.bb 1.3 KB

1234567891011121314151617181920212223242526272829303132333435
  1. DESCRIPTION = "A simple memory benchmark program, which tries to measure the \
  2. peak bandwidth of sequential memory accesses and the latency of random memory \
  3. accesses. Bandwidth is measured by running different assembly code for the \
  4. aligned memory blocks and attempting different prefetch strategies"
  5. HOMEPAGE = "https://github.com/ssvb/tinymembench/wiki"
  6. LICENSE = "MIT"
  7. LIC_FILES_CHKSUM = "file://main.c;endline=22;md5=879b9bbb60851454885b5fa47eb6b345"
  8. PV = "0.4.0+git${SRCPV}"
  9. SRCREV = "a2cf6d7e382e3aea1eb39173174d9fa28cad15f3"
  10. SRC_URI = "git://github.com/ssvb/tinymembench.git \
  11. file://0001-asm-Delete-.func-.endfunc-directives.patch \
  12. "
  13. S = "${WORKDIR}/git"
  14. TARGET_CC_ARCH += "${LDFLAGS}"
  15. do_install() {
  16. install -d ${D}${bindir}
  17. install -m755 tinymembench ${D}${bindir}/
  18. }
  19. # Fails to build with thumb-1 (qemuarm)
  20. #| {standard input}: Assembler messages:
  21. #| {standard input}:66: Error: instruction not supported in Thumb16 mode -- `subs r1,r1,#16'
  22. #| {standard input}:69: Error: instruction not supported in Thumb16 mode -- `subs r1,r1,#16'
  23. #| {standard input}:82: Error: selected processor does not support Thumb mode `mla r3,r4,r3,r5'
  24. #| {standard input}:82: Error: unshifted register required -- `and r8,r7,r3,lsr#16'
  25. ARM_INSTRUCTION_SET = "arm"
  26. #
  27. # Does not work for 64bit mips.
  28. #
  29. COMPATIBLE_HOST = "^(?!mips64).*"