sysbench_0.4.12.bb 1.1 KB

1234567891011121314151617181920212223242526
  1. SUMMARY = "System performance benchmark"
  2. HOMEPAGE = "http://github.com/akopytov/sysbench"
  3. SECTION = "console/tests"
  4. LICENSE = "GPLv2"
  5. LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
  6. inherit autotools
  7. # The project has moved from Sourceforge to Launchpad, to Github. Use the source tarball from
  8. # Launchpad until the next release is available from Github.
  9. SRC_URI = "https://launchpad.net/ubuntu/+archive/primary/+files/${BPN}_${PV}.orig.tar.gz"
  10. SRC_URI[md5sum] = "3a6d54fdd3fe002328e4458206392b9d"
  11. SRC_URI[sha256sum] = "83fa7464193e012c91254e595a89894d8e35b4a38324b52a5974777e3823ea9e"
  12. PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'largefile', d)}"
  13. PACKAGECONFIG[largefile] = "--enable-largefile,--disable-largefile,,"
  14. PACKAGECONFIG[aio] = "--enable-aio,--disable-aio,libaio,"
  15. PACKAGECONFIG[mysql] = "--with-mysql \
  16. --with-mysql-includes=${STAGING_INCDIR}/mysql \
  17. --with-mysql-libs=${STAGING_LIBDIR}, \
  18. --without-mysql,mysql5"
  19. do_configure_prepend() {
  20. touch ${S}/NEWS ${S}/AUTHORS
  21. }