memtester_4.5.0.bb 790 B

12345678910111213141516171819202122232425
  1. SUMMARY = "Utility to test for faulty memory subsystem"
  2. HOMEPAGE = "http://pyropus.ca/software/memtester/"
  3. SECTION = "console/utils"
  4. LICENSE = "GPLv2"
  5. LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3"
  6. SRC_URI = "http://pyropus.ca/software/memtester/old-versions/${BP}.tar.gz \
  7. file://Makefile.patch \
  8. "
  9. SRC_URI[md5sum] = "674a8a88ff54bdb229ca4148218a41f1"
  10. SRC_URI[sha256sum] = "8ed52b0d06d4aeb61954994146e2a5b2d20448a8f3ce3ee995120e6dbde2ae37"
  11. do_compile () {
  12. echo '${CC} ${CFLAGS} -DPOSIX -c' > conf-cc
  13. echo '${CC} ${LDFLAGS}' > conf-ld
  14. oe_runmake
  15. }
  16. do_install () {
  17. install -d ${D}${bindir}
  18. install -d ${D}${mandir}/man8
  19. install -m 0755 memtester ${D}${bindir}/
  20. install -m 0755 memtester.8 ${D}${mandir}/man8/
  21. }