iozone3_490.bb 4.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121
  1. SUMMARY = "Filesystem and Disk Benchmarking Tool"
  2. HOMEPAGE = "http://www.iozone.org/"
  3. AUTHOR = "Don Capps <don.capps2@verizon.net>, William D. Norcott <wnorcott@us.oracle.com>"
  4. SECTION = "console/tests"
  5. LICENSE = "iozone3"
  6. LIC_FILES_CHKSUM = "file://iozone.c;beginline=37;endline=48;md5=7331260091868dcad0f9edea735b5f4b \
  7. file://iozone.c;beginline=276;endline=282;md5=77f9ee51e45b57a7e7519c4fa0b4f00b \
  8. "
  9. SRC_URI = "http://www.iozone.org/src/current/${BPN}_${PV}.tar \
  10. file://parallelism.patch \
  11. file://0001-let-system-headers-provide-pread64.patch \
  12. file://copyright.txt \
  13. "
  14. SRC_URI[md5sum] = "95cb73dfdd58a0dfa42804f016dbb83c"
  15. SRC_URI[sha256sum] = "5eadb4235ae2a956911204c50ebf2d8d8d59ddcd4a2841a1baf42f3145ad4fed"
  16. UPSTREAM_CHECK_REGEX = "iozone3_(?P<pver>\d+).tar"
  17. S = "${WORKDIR}/${BPN}_${PV}/src/current"
  18. #
  19. # All other arches can use the default OEMAKE except those
  20. # explicitly listed below. Another, the iozone3 Makefile
  21. # needs to be told about the cross-compiler explicitly here.
  22. #
  23. EXTRA_OEMAKE_powerpc = "linux-powerpc CC='${CC}' GCC='${CC}'"
  24. EXTRA_OEMAKE_powerpc64 = "linux-powerpc64 CC='${CC}' GCC='${CC}'"
  25. EXTRA_OEMAKE_powerpc64le = "linux-powerpc64 CC='${CC}' GCC='${CC}'"
  26. EXTRA_OEMAKE_x86-64 = "linux-AMD64 CC='${CC}' GCC='${CC}'"
  27. EXTRA_OEMAKE_arm = "linux-arm CC='${CC}' GCC='${CC}'"
  28. EXTRA_OEMAKE = "linux CC='${CC}' GCC='${CC}'"
  29. TARGET_CC_ARCH += "${LDFLAGS}"
  30. do_install() {
  31. install -d ${D}${bindir} \
  32. ${D}${mandir}/man1 \
  33. ${D}${datadir}/doc/${BPN}/examples
  34. install -m 0755 ${S}/iozone ${D}${bindir}
  35. install -m 0755 ${S}/fileop ${D}${bindir}
  36. install -m 0644 ${WORKDIR}/${BPN}_${PV}/docs/iozone.1 ${D}${mandir}/man1/
  37. install -m 0644 ${WORKDIR}/copyright.txt ${D}${datadir}/doc/${BPN}/
  38. install -m 0644 ${S}/*.dem ${D}${datadir}/doc/${BPN}/examples
  39. install -m 0644 ${S}/client_list ${D}${datadir}/doc/${BPN}/examples
  40. install -m 0644 ${S}/Gnuplot.txt ${D}${datadir}/doc/${BPN}/examples
  41. install -m 0755 ${S}/Generate_Graphs ${D}${datadir}/doc/${BPN}/examples
  42. install -m 0755 ${S}/gengnuplot.sh ${D}${datadir}/doc/${BPN}/examples
  43. install -m 0755 ${S}/report.pl ${D}${datadir}/doc/${BPN}/examples
  44. install -m 0644 ${WORKDIR}/${BPN}_${PV}/docs/Iozone_ps.gz ${D}${datadir}/doc/${BPN}/
  45. install -m 0644 ${WORKDIR}/${BPN}_${PV}/docs/IOzone_msword_98.pdf ${D}${datadir}/doc/${BPN}/
  46. install -m 0644 ${WORKDIR}/${BPN}_${PV}/docs/Run_rules.doc ${D}${datadir}/doc/${BPN}/
  47. }
  48. FILES_${PN} += "${datadir}/doc/${PN}/copyright.txt"
  49. # LICENSE:
  50. #
  51. # Copyright 1991, 1992, 1994, 1998, 1999, 2002 William D. Norcott
  52. #
  53. # License to freely use and distribute this software is hereby granted
  54. # by the author, subject to the condition that this copyright notice
  55. # remains intact. The author retains the exclusive right to publish
  56. # derivative works based on this work, including, but not limited to
  57. # revised versions of this work.
  58. #
  59. #
  60. # Below is author reply to question about distributing iozone3 in
  61. # OpenEmbedded:
  62. #
  63. # ========================================================================
  64. #
  65. # Marcin,
  66. #
  67. # Re-distribution is permitted as long as the copyright is
  68. # maintained and the source code is not changed. I do not
  69. # see a problem with your mods to enable fileop for Linux-arm,
  70. # as these mods have been returned to the Iozone folks,
  71. # and they have been accepted for inclusion in the next
  72. # release :-)
  73. #
  74. # Thank you for your contribution,
  75. # Don Capps
  76. #
  77. # ----- Original Message -----
  78. # From: "Marcin Juszkiewicz" <firma@hrw.one.pl>
  79. # To: "Don Capps" <don.capps2@verizon.net>; "William D. Norcott"
  80. # <wnorcott@us.oracle.com>
  81. # Sent: Sunday, October 29, 2006 4:55 PM
  82. # Subject: iozone3 263 patch for arm and License question
  83. #
  84. #
  85. # > Morning
  86. # >
  87. # > I want to include iozone3 in OpenEmbedded [1] metadata to give it for
  88. # > other developers. Currently OE is used to build few distributions for
  89. # > misc platforms: ARM, SH3, SH4, x86, PowerPC and different types of
  90. # > machines (PDA, settopbox, devboards, desktops, thin clients, routers).
  91. # >
  92. # > According to your distribution of derivations is forbidden. Packaging
  93. # > iozone3 in OpenEmbedded will not involve any source code changes. But
  94. # > when I was building it for ARM I discovered that fileop binary was not
  95. # > built - so I created patch for it (attached). Not yet tested it on target
  96. # > device.
  97. # >
  98. # > Thus, I seek your written permission via e-mail to distribute a package of
  99. # > the unmodified source code and also a package of the pre-compiled binary.
  100. # > Your copyright statement will be included in the package.
  101. # >
  102. # >
  103. # > 1. http://www.openembedded.org/
  104. # >
  105. # > Regards
  106. # > --
  107. # > JID: hrw-jabber.org
  108. # > OpenEmbedded developer/consultant