fio_3.25.bb 1.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445
  1. SUMMARY = "Filesystem and hardware benchmark and stress tool"
  2. DESCRIPTION = "fio is an I/O tool meant to be used both for benchmark and \
  3. stress/hardware verification. It has support for a number of I/O engines, \
  4. I/O priorities (for newer Linux kernels), rate I/O, forked or threaded jobs, \
  5. and much more. It can work on block devices as well as files. fio accepts \
  6. job descriptions in a simple-to-understand text format. Several example job \
  7. files are included. fio displays all sorts of I/O performance information."
  8. HOMEPAGE = "http://freecode.com/projects/fio"
  9. SECTION = "console/tests"
  10. LICENSE = "GPLv2"
  11. LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
  12. DEPENDS = "libaio zlib coreutils-native"
  13. DEPENDS += "${@bb.utils.contains('MACHINE_FEATURES', 'pmem', 'pmdk', '', d)}"
  14. RDEPENDS_${PN} = "python3-core bash"
  15. PACKAGECONFIG_NUMA = "numa"
  16. # ARM does not currently support NUMA
  17. PACKAGECONFIG_NUMA_arm = ""
  18. PACKAGECONFIG_NUMA_armeb = ""
  19. PACKAGECONFIG ??= "${PACKAGECONFIG_NUMA}"
  20. PACKAGECONFIG[numa] = ",--disable-numa,numactl"
  21. SRCREV = "fd80924b22fef6ce0d5580724d91490347445f90"
  22. SRC_URI = "git://git.kernel.dk/fio.git \
  23. "
  24. S = "${WORKDIR}/git"
  25. # avoids build breaks when using no-static-libs.inc
  26. DISABLE_STATIC = ""
  27. EXTRA_OEMAKE = "CC='${CC}' LDFLAGS='${LDFLAGS}'"
  28. EXTRA_OECONF = "${@bb.utils.contains('MACHINE_FEATURES', 'x86', '--disable-optimizations', '', d)}"
  29. do_configure() {
  30. ./configure ${EXTRA_OECONF}
  31. }
  32. do_install() {
  33. oe_runmake install DESTDIR=${D} prefix=${prefix} mandir=${mandir}
  34. install -d ${D}/${docdir}/${PN}
  35. cp -R --no-dereference --preserve=mode,links -v ${S}/examples ${D}/${docdir}/${PN}/
  36. }