gpe.bbclass 405 B

1234567891011121314151617
  1. DEPENDS_prepend = "virtual/libintl intltool-native "
  2. GPE_TARBALL_SUFFIX ?= "gz"
  3. SRC_URI = "${GPE_MIRROR}/${BP}.tar.${GPE_TARBALL_SUFFIX}"
  4. FILES_${PN} += "${datadir}/gpe ${datadir}/application-registry"
  5. SECTION ?= "gpe"
  6. inherit gettext
  7. gpe_do_compile() {
  8. oe_runmake PREFIX=${prefix}
  9. }
  10. gpe_do_install() {
  11. oe_runmake PREFIX=${prefix} DESTDIR=${D} install
  12. }
  13. EXPORT_FUNCTIONS do_compile do_install