crossguid_0.2.2.bb 639 B

1234567891011121314151617181920
  1. # Copyright (C) 2017 Khem Raj <raj.khem@gmail.com>
  2. # Released under the MIT license (see COPYING.MIT for the terms)
  3. DESCRIPTION = "Lightweight cross platform C++ GUID/UUID library"
  4. HOMEPAGE = "https://github.com/graeme-hill/crossguid"
  5. LICENSE = "MIT"
  6. LIC_FILES_CHKSUM = "file://LICENSE;md5=1373274bc8d8001edc54933919f36f68"
  7. DEPENDS += "util-linux"
  8. SRCREV = "5b45cdd9a56ca9da35ee0f8845cb4e2603d245dc"
  9. SRC_URI = "git://github.com/graeme-hill/crossguid;protocol=https"
  10. S = "${WORKDIR}/git"
  11. inherit cmake
  12. do_install() {
  13. install -D -m 0644 ${B}/libxg.a ${D}${libdir}/libxg.a
  14. install -D -m 0644 ${S}/Guid.hpp ${D}${includedir}/Guid.hpp
  15. }