vlc_3.0.11.1.bb 5.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136
  1. DESCRIPTION = "Video player and streamer - davinci edition"
  2. HOMEPAGE = "http://www.videolan.org"
  3. SECTION = "multimedia"
  4. LICENSE = "GPL-2.0"
  5. LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
  6. DEPENDS = "coreutils-native fribidi libtool libgcrypt libgcrypt-native \
  7. dbus libxml2 gnutls \
  8. tremor faad2 ffmpeg flac alsa-lib \
  9. lua-native lua libidn \
  10. avahi jpeg xz libmodplug mpeg2dec \
  11. libmtp libopus orc libsamplerate0 libusb1 schroedinger taglib \
  12. tiff"
  13. LDFLAGS_append_riscv64 = " -latomic"
  14. LDFLAGS_append_riscv32 = " -latomic"
  15. # While this item does not require it, it depends on ffmpeg which does
  16. LICENSE_FLAGS = "commercial"
  17. SRC_URI = "http://download.videolan.org/pub/videolan/${BPN}/${PV}/${BP}.tar.xz \
  18. file://0001-make-opencv-configurable.patch \
  19. file://0002-use-vorbisidec.patch \
  20. file://0003-fix-luaL-checkint.patch \
  21. file://0004-Use-packageconfig-to-detect-mmal-support.patch \
  22. file://0005-Fix-build-with-Qt-5.15.patch \
  23. file://0001-linux-thread-Use-SYS_futex-instead-of-__NR_futex.patch \
  24. "
  25. SRC_URI[sha256sum] = "189311d28aa814f106a7b3645211ac52c0b3e2b9f4b348de2f63bab3218086b8"
  26. inherit autotools features_check gettext pkgconfig mime-xdg
  27. REQUIRED_DISTRO_FEATURES = "x11"
  28. export BUILDCC = "${BUILD_CC}"
  29. EXTRA_OECONF = "\
  30. --enable-run-as-root \
  31. --enable-xvideo \
  32. --disable-screen --disable-caca \
  33. --enable-vlm \
  34. --enable-freetype \
  35. --enable-tremor \
  36. --enable-v4l2 --disable-aa --disable-faad \
  37. --enable-dbus \
  38. --without-contrib \
  39. --without-kde-solid \
  40. --enable-realrtsp \
  41. --disable-libtar \
  42. --enable-avcodec \
  43. ac_cv_path_MOC=${STAGING_BINDIR_NATIVE}${QT_DIR_NAME}/moc \
  44. ac_cv_path_RCC=${STAGING_BINDIR_NATIVE}${QT_DIR_NAME}/rcc \
  45. ac_cv_path_UIC=${STAGING_BINDIR_NATIVE}${QT_DIR_NAME}/uic \
  46. "
  47. PACKAGECONFIG ?= " \
  48. live555 dc1394 dv1394 notify fontconfig fluidsynth freetype dvdread png \
  49. ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11', '', d)} \
  50. x264 \
  51. "
  52. inherit ${@bb.utils.contains('PACKAGECONFIG', 'qt5', 'qmake5_paths', '', d)}
  53. PACKAGECONFIG[mmal] = "--enable-omxil --enable-omxil-vout --enable-rpi-omxil --enable-mmal,,userland"
  54. PACKAGECONFIG[x264] = "--enable-x264,--disable-x264,x264"
  55. PACKAGECONFIG[fluidsynth] = ",,fluidsynth"
  56. PACKAGECONFIG[mad] = "--enable-mad,--disable-mad,libmad"
  57. PACKAGECONFIG[a52] = "--enable-a52,--disable-a52,liba52"
  58. PACKAGECONFIG[jack] = "--enable-jack,--disable-jack,jack"
  59. PACKAGECONFIG[live555] = "--enable-live555 LIVE555_PREFIX=${STAGING_DIR_HOST}${prefix},--disable-live555,live555"
  60. PACKAGECONFIG[libass] = "--enable-libass,--disable-libass,libass"
  61. PACKAGECONFIG[postproc] = "--enable-postproc,--disable-postproc,libpostproc"
  62. PACKAGECONFIG[libva] = "--enable-libva,--disable-libva,libva"
  63. PACKAGECONFIG[opencv] = "--enable-opencv,--disable-opencv,opencv"
  64. PACKAGECONFIG[speex] = "--enable-speex,--disable-speex,speex"
  65. PACKAGECONFIG[gstreamer] = "--enable-gst-decode,--disable-gst-decode,gstreamer1.0 gstreamer1.0-plugins-base gstreamer1.0-plugins-bad"
  66. PACKAGECONFIG[vpx] = "--enable-vpx,--disable-vpx, libvpx"
  67. PACKAGECONFIG[qt5] = "--enable-qt,--disable-qt, qtbase-native qtx11extras qtsvg"
  68. PACKAGECONFIG[freerdp] = "--enable-freerdp,--disable-freerdp, freerdp"
  69. PACKAGECONFIG[dvbpsi] = "--enable-dvbpsi,--disable-dvbpsi, libdvbpsi"
  70. PACKAGECONFIG[samba] = "--enable-smbclient,--disable-smbclient, samba"
  71. PACKAGECONFIG[upnp] = "--enable-upnp,--disable-upnp,libupnp"
  72. PACKAGECONFIG[dvdnav] = "--enable-dvdnav,--disable-dvdnav,libdvdnav libdvdcss"
  73. PACKAGECONFIG[sftp] = "--enable-sftp,--disable-sftp,libssh2"
  74. PACKAGECONFIG[vorbis] = "--enable-vorbis,--disable-vorbis,libvorbis libogg"
  75. PACKAGECONFIG[ogg] = "--enable-ogg,--disable-ogg,libvorbis libogg"
  76. PACKAGECONFIG[dc1394] = "--enable-dc1394,--disable-dc1394,libdc1394"
  77. PACKAGECONFIG[dv1394] = "--enable-dv1394,--disable-dv1394,libraw1394 libavc1394"
  78. PACKAGECONFIG[svg] = "--enable-svg,--disable-svg,librsvg"
  79. PACKAGECONFIG[svgdec] = "--enable-svgdec,--disable-svgdec,librsvg cairo"
  80. PACKAGECONFIG[notify] = "--enable-notify,--disable-notify, libnotify gtk+3"
  81. PACKAGECONFIG[fontconfig] = "--enable-fontconfig,--disable-fontconfig, fontconfig"
  82. PACKAGECONFIG[freetype] = "--enable-freetype,--disable-freetype, freetype"
  83. PACKAGECONFIG[dvdread] = "--enable-dvdread,--disable-dvdread, libdvdread libdvdcss"
  84. PACKAGECONFIG[vnc] = "--enable-vnc,--disable-vnc, libvncserver"
  85. PACKAGECONFIG[x11] = "--with-x --enable-xcb,--without-x --disable-xcb, xcb-util-keysyms libxpm libxinerama"
  86. PACKAGECONFIG[png] = "--enable-png,--disable-png,libpng"
  87. PACKAGECONFIG[vdpau] = "--enable-vdpau,--disable-vdpau,libvdpau"
  88. PACKAGECONFIG[wayland] = "--enable-wayland,--disable-wayland,wayland wayland-native"
  89. do_configure_append() {
  90. sed -i -e s:'${top_builddir_slash}libtool':'${top_builddir_slash}'${TARGET_SYS}-libtool:g ${B}/doltlibtool
  91. # moc needs support: precreate build paths
  92. for qtpath in adapters components/epg components/playlist components/sout dialogs managers styles util/buttons; do
  93. mkdir -p "${B}/modules/gui/qt/$qtpath"
  94. done
  95. }
  96. # This recipe packages vlc as a library as well, so qt4 dependencies
  97. # can be avoided when only the library is installed.
  98. PACKAGES =+ "libvlc"
  99. LEAD_SONAME_libvlc = "libvlc.so.5"
  100. FILES_libvlc = "${libdir}/lib*.so.*"
  101. FILES_${PN} += "\
  102. ${bindir}/vlc \
  103. ${libdir}/vlc/vlc/libvlc_vdpau.so \
  104. ${datadir}/applications \
  105. ${datadir}/vlc/ \
  106. ${datadir}/icons \
  107. ${datadir}/metainfo/vlc.appdata.xml \
  108. "
  109. FILES_${PN}-dbg += "\
  110. ${libdir}/vlc/*/.debug \
  111. ${libdir}/vlc/plugins/*/.debug \
  112. "
  113. FILES_${PN}-staticdev += "\
  114. ${libdir}/vlc/plugins/*/*.a \
  115. "
  116. INSANE_SKIP_${PN} = "dev-so"