libmusicbrainz_git.bb 1.4 KB

12345678910111213141516171819202122232425262728293031323334353637383940
  1. SUMMARY = "MusicBrainz client library"
  2. DESCRIPTION = "The MusicBrainz client is a library which can be built into other programs. The library allows you to access the data held on the MusicBrainz server."
  3. HOMEPAGE = "http://musicbrainz.org"
  4. LICENSE = "LGPLv2.1+"
  5. LIC_FILES_CHKSUM = "file://COPYING.txt;md5=fbc093901857fcd118f065f900982c24"
  6. DEPENDS = "expat libxml2 libxml2-native neon neon-native"
  7. PV = "5.1.0+git${SRCPV}"
  8. SRCREV = "44c05779dd996035758f5ec426766aeedce29cc3"
  9. SRC_URI = "git://github.com/metabrainz/libmusicbrainz.git \
  10. file://allow-libdir-override.patch "
  11. S = "${WORKDIR}/git"
  12. inherit cmake pkgconfig
  13. do_configure_prepend() {
  14. # The native build really doesn't like being rebuilt, so delete
  15. # it if it's already present. Also delete all other files not
  16. # known to Git to fix subsequent invocations of do_configure.
  17. git clean -dfx -e /.pc/ -e /patches/ .
  18. mkdir build-native
  19. cd build-native
  20. LDFLAGS="${BUILD_LDFLAGS}" \
  21. cmake -DCMAKE_C_FLAGS=${BUILD_CFLAGS} \
  22. -DCMAKE_C_COMPILER=${BUILD_CC} \
  23. -DCMAKE_CXX_FLAGS=${BUILD_CXXFLAGS} \
  24. -DCMAKE_CXX_COMPILER=${BUILD_CXX} \
  25. -DCMAKE_EXE_LINKER_FLAGS=${BUILD_LDFLAGS} \
  26. ..
  27. make make-c-interface
  28. cd ..
  29. }
  30. EXTRA_OECMAKE = "-DLIB_INSTALL_DIR:PATH=${libdir} \
  31. -DIMPORT_EXECUTABLES=build-native/ImportExecutables.cmake"
  32. # out-of-tree building doesn't appear to work for this package.
  33. B = "${S}"