tracker_2.3.6.bb 1.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051
  1. SUMMARY = "Tracker is a file search engine"
  2. LICENSE = "GPLv2 & LGPLv2.1"
  3. LIC_FILES_CHKSUM = " \
  4. file://COPYING.GPL;md5=ee31012bf90e7b8c108c69f197f3e3a4 \
  5. file://COPYING.LGPL;md5=2d5025d4aa3495befef8f17206a5b0a1 \
  6. "
  7. DEPENDS = " \
  8. libxml2-native \
  9. dbus-native \
  10. glib-2.0 \
  11. sqlite3 \
  12. libarchive \
  13. dbus \
  14. icu \
  15. json-glib \
  16. libsoup-2.4 \
  17. libstemmer \
  18. "
  19. GNOMEBASEBUILDCLASS = "meson"
  20. inherit gnomebase gsettings gobject-introspection vala gtk-doc manpages bash-completion features_check
  21. SRC_URI[archive.sha256sum] = "bd1eb4122135296fa7b57b1c3fa0ed602cf7d06c0b8e534d0bd17ff5f97feef2"
  22. # gobject-introspection is mandatory and cannot be configured
  23. REQUIRED_DISTRO_FEATURES = "gobject-introspection-data"
  24. UNKNOWN_CONFIGURE_WHITELIST_append = " introspection"
  25. PACKAGECONFIG ??= "fts"
  26. PACKAGECONFIG[networkmanager] = "-Dnetwork_manager=enabled,-Dnetwork_manager=disabled,networkmanger"
  27. # full text search requires sqlite3 build with PACKAGECONFIG[fts5] set
  28. PACKAGECONFIG[fts] = "-Dfts=true,-Dfts=false"
  29. # set required cross property sqlite3_has_fts5
  30. do_write_config[vardeps] += "PACKAGECONFIG"
  31. do_write_config_append() {
  32. echo "[properties]" > ${WORKDIR}/meson-tracker.cross
  33. echo "sqlite3_has_fts5 = '${@bb.utils.contains('PACKAGECONFIG', 'fts', 'true', 'false', d)}'" >> ${WORKDIR}/meson-tracker.cross
  34. }
  35. EXTRA_OEMESON = "--cross-file ${WORKDIR}/meson-tracker.cross \
  36. -Dsystemd_user_services=${systemd_user_unitdir} \
  37. "
  38. FILES_${PN} += " \
  39. ${datadir}/dbus-1 \
  40. ${libdir}/tracker-2.0 \
  41. ${systemd_user_unitdir} \
  42. "