mutter_3.34.6.bb 3.3 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667686970717273747576777879808182838485868788899091929394959697
  1. SUMMARY = "Window and compositing manager based on Clutter"
  2. LICENSE = "GPLv2"
  3. LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
  4. DEPENDS = " \
  5. xserver-xorg-cvt-native \
  6. virtual/libx11 \
  7. gtk+3 \
  8. gdk-pixbuf \
  9. cairo \
  10. pango \
  11. gsettings-desktop-schemas \
  12. json-glib \
  13. gnome-desktop3 \
  14. gnome-settings-daemon \
  15. libxtst \
  16. libxkbfile \
  17. xinerama \
  18. "
  19. GNOMEBASEBUILDCLASS = "meson"
  20. inherit gnomebase gsettings gobject-introspection gettext upstream-version-is-even features_check
  21. SRC_URI[archive.md5sum] = "20913c458406e6efa3df005a3ce48c8e"
  22. SRC_URI[archive.sha256sum] = "23bde87d33b8981358831cec8915bb5ff1eaf9c1de74c90cd1660b1b95883526"
  23. SRC_URI += "file://0001-EGL-Include-EGL-eglmesaext.h.patch"
  24. # x11 is still manadatory - see meson.build
  25. REQUIRED_DISTRO_FEATURES = "x11"
  26. # systemd can be replaced by libelogind (not available atow - make systemd
  27. # mandatory distro feature)
  28. LOGIND ?= "systemd"
  29. REQUIRED_DISTRO_FEATURES += "systemd"
  30. # profiler requires sysprof 3.34 which is not willing to build atow
  31. PACKAGECONFIG ??= " \
  32. native-backend \
  33. ${@bb.utils.contains('DISTRO_FEATURES', 'opengl x11', 'opengl glx', '', d)} \
  34. sm \
  35. startup-notification \
  36. ${@bb.utils.contains('DISTRO_FEATURES', 'opengl wayland', 'wayland', '', d)} \
  37. "
  38. EXTRA_OEMESON += " \
  39. -Dxwayland_path=${bindir}/Xwayland \
  40. "
  41. # combi-config - see meson_options.txt for more details
  42. PACKAGECONFIG[native-backend] = "-Dnative_backend=true -Dudev=true, -Dnative_backend=false -Dudev=false, libdrm virtual/libgbm libinput ${LOGIND} virtual/egl virtual/libgles2 udev"
  43. PACKAGECONFIG[opengl] = "-Dopengl=true, -Dopengl=true, virtual/libgl"
  44. PACKAGECONFIG[glx] = "-Dglx=true, -Dglx=false"
  45. PACKAGECONFIG[libwacom] = "-Dlibwacom=true, -Dlibwacom=false, libwacom"
  46. # Remove depending on pipewire-0.2 when mutter is upgraded to 3.36+
  47. PACKAGECONFIG[remote-desktop] = "-Dremote_desktop=true, -Dremote_desktop=false, pipewire-0.2"
  48. PACKAGECONFIG[sm] = "-Dsm=true, -Dsm=false, libsm"
  49. PACKAGECONFIG[profiler] = "-Dprofiler=true,-Dprofiler=false,sysprof"
  50. PACKAGECONFIG[startup-notification] = "-Dstartup_notification=true, -Dstartup_notification=false, startup-notification, startup-notification"
  51. PACKAGECONFIG[wayland] = "-Dwayland=true,-Dwayland=false,wayland wayland-native, xserver-xorg-xwayland"
  52. PACKAGECONFIG[wayland-eglstream] = "-Dwayland_eglstream=true,-Dwayland_eglstream=false"
  53. # yes they changed from mutter-4 -> mutter-5 recently so be perpared
  54. MUTTER_API_NAME = "mutter-5"
  55. do_install_append() {
  56. # Add gir links in standard paths. That makes dependents life much easier
  57. # to find them
  58. install -d ${D}${datadir}/gir-1.0
  59. for gir_full in `find ${D}${libdir}/${MUTTER_API_NAME} -name '*.gir'`; do
  60. gir=`basename "$gir_full"`
  61. ln -sr "${D}${libdir}/${MUTTER_API_NAME}/$gir" "${D}${datadir}/gir-1.0/$gir"
  62. done
  63. }
  64. PACKAGES =+ "${PN}-tests"
  65. FILES_${PN} += " \
  66. ${datadir}/gnome-control-center \
  67. ${libdir}/${MUTTER_API_NAME}/lib*${SOLIBS} \
  68. ${libdir}/${MUTTER_API_NAME}/*.typelib \
  69. ${libdir}/${MUTTER_API_NAME}/plugins \
  70. "
  71. FILES_${PN}-tests += " \
  72. ${datadir}/installed-tests \
  73. ${datadir}/${MUTTER_API_NAME}/tests \
  74. ${libexecdir}/installed-tests/${MUTTER_API_NAME} \
  75. "
  76. FILES_${PN}-dev += " \
  77. ${libdir}/${MUTTER_API_NAME}/*.gir \
  78. ${libdir}/${MUTTER_API_NAME}/lib*.so \
  79. "
  80. RDEPENDS_${PN} += "zenity"