gnome-shell_3.34.5.bb 1.8 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364
  1. SUMMARY = "GNOME Shell is the graphical shell of the GNOME desktop environment"
  2. LICENSE = "GPLv2"
  3. LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
  4. GNOMEBASEBUILDCLASS = "meson"
  5. inherit gnomebase gsettings gettext gobject-introspection features_check upstream-version-is-even bash-completion
  6. REQUIRED_DISTRO_FEATURES = "x11 polkit systemd pam"
  7. DEPENDS = " \
  8. libxml2-native \
  9. sassc-native \
  10. gtk+3 \
  11. mutter \
  12. evolution-data-server \
  13. gcr \
  14. gjs \
  15. gnome-autoar \
  16. polkit \
  17. libcroco \
  18. startup-notification \
  19. ibus \
  20. gsettings-desktop-schemas \
  21. "
  22. GTKDOC_MESON_OPTION = "gtk_doc"
  23. # gobject-introspection is mandatory and cannot be configured
  24. REQUIRED_DISTRO_FEATURES += "gobject-introspection-data"
  25. UNKNOWN_CONFIGURE_WHITELIST_append = " introspection"
  26. SRC_URI[archive.md5sum] = "4bd27c8a91d30fde78cb69b94677cf1f"
  27. SRC_URI[archive.sha256sum] = "d296f318a74a6d7883358a6ce1c4d8808b7903dbbb4f9c61ab4230f18e6d7550"
  28. PACKAGECONFIG ??= "bluetooth nm ${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}"
  29. PACKAGECONFIG[bluetooth] = ",,gnome-bluetooth"
  30. PACKAGECONFIG[nm] = "-Dnetworkmanager=true, -Dnetworkmanager=false, networkmanager"
  31. PACKAGECONFIG[systemd] = "-Dsystemd=true, -Dsystemd=false, systemd"
  32. EXTRA_OEMESON = " \
  33. -Dman=false \
  34. "
  35. do_install_append() {
  36. # fix shebangs
  37. for tool in `find ${D}${bindir} -name '*-tool'`; do
  38. sed -i 's:#!${PYTHON}:#!${bindir}/${PYTHON_PN}:' $tool
  39. done
  40. }
  41. FILES_${PN} += " \
  42. ${datadir}/dbus-1 \
  43. ${datadir}/gnome-control-center \
  44. ${datadir}/xdg-desktop-portal \
  45. ${systemd_user_unitdir} \
  46. "
  47. RDEPENDS_${PN} += "gsettings-desktop-schemas gdm-base librsvg-gtk"
  48. PACKAGES =+ "${PN}-tools"
  49. FILES_${PN}-tools = "${bindir}/*-tool"
  50. RDEPENDS_${PN}-tools = "python3-core"