sshfs-fuse_3.7.1.bb 698 B

123456789101112131415161718192021222324252627
  1. SUMMARY = "This is a filesystem client based on the SSH File Transfer Protocol using FUSE"
  2. AUTHOR = "Miklos Szeredi <miklos@szeredi.hu>"
  3. HOMEPAGE = "https://github.com/libfuse/sshfs"
  4. SECTION = "console/network"
  5. LICENSE = "GPLv2"
  6. DEPENDS = "glib-2.0 fuse3"
  7. LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
  8. SRC_URI = "git://github.com/libfuse/sshfs"
  9. SRCREV = "8059e2ce630dd2b984f7a6c44a2b5291b0fe2abc"
  10. S = "${WORKDIR}/git"
  11. inherit meson ptest
  12. SRC_URI += " \
  13. file://run-ptest \
  14. "
  15. RDEPENDS_${PN}-ptest += " \
  16. ${PYTHON_PN}-pytest \
  17. bash \
  18. "
  19. do_install_ptest() {
  20. install -d ${D}${PTEST_PATH}/test
  21. cp -rf ${S}/test/* ${D}${PTEST_PATH}/test/
  22. }