ntfs-3g-ntfsprogs_2017.3.23.bb 1.9 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152
  1. DESCRIPTION = "The NTFS-3G driver is an open source, freely available NTFS driver for Linux with read and write support."
  2. HOMEPAGE = "http://www.ntfs-3g.org/"
  3. DEPENDS = "fuse libgcrypt"
  4. PROVIDES = "ntfsprogs ntfs-3g"
  5. LICENSE = "GPLv2 & LGPLv2"
  6. LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552 \
  7. file://COPYING.LIB;md5=f30a9716ef3762e3467a2f62bf790f0a"
  8. SRC_URI = "http://tuxera.com/opensource/ntfs-3g_ntfsprogs-${PV}.tgz \
  9. file://0001-libntfs-3g-Makefile.am-fix-install-failed-while-host.patch \
  10. "
  11. S = "${WORKDIR}/ntfs-3g_ntfsprogs-${PV}"
  12. SRC_URI[md5sum] = "d97474ae1954f772c6d2fa386a6f462c"
  13. SRC_URI[sha256sum] = "3e5a021d7b761261836dcb305370af299793eedbded731df3d6943802e1262d5"
  14. UPSTREAM_CHECK_URI = "https://www.tuxera.com/community/open-source-ntfs-3g/"
  15. UPSTREAM_CHECK_REGEX = "ntfs-3g_ntfsprogs-(?P<pver>\d+(\.\d+)+)\.tgz"
  16. inherit autotools pkgconfig
  17. PACKAGECONFIG ??= ""
  18. PACKAGECONFIG[uuid] = "--with-uuid,--without-uuid,util-linux"
  19. # required or it calls ldconfig at install step
  20. EXTRA_OEMAKE = "LDCONFIG=echo"
  21. PACKAGES =+ "ntfs-3g ntfsprogs libntfs-3g"
  22. FILES_ntfs-3g = "${base_sbindir}/*.ntfs-3g ${bindir}/ntfs-3g* ${base_sbindir}/mount.ntfs"
  23. RDEPENDS_ntfs-3g += "fuse"
  24. RRECOMMENDS_ntfs-3g = "util-linux-mount"
  25. FILES_ntfsprogs = "${base_sbindir}/* ${bindir}/* ${sbindir}/*"
  26. FILES_libntfs-3g = "${libdir}/*${SOLIBS}"
  27. do_install_append() {
  28. # Standard mount will execute the program /sbin/mount.TYPE when called.
  29. # Add a symbolic link to let mount find ntfs.
  30. ln -sf mount.ntfs-3g ${D}${base_sbindir}/mount.ntfs
  31. rmdir ${D}${libdir}/ntfs-3g
  32. # Handle when usrmerge is in effect. Some files are installed to /sbin
  33. # regardless of the value of ${base_sbindir}.
  34. if [ "${base_sbindir}" != /sbin ] && [ -d ${D}/sbin ]; then
  35. mkdir -p ${D}${base_sbindir}
  36. mv ${D}/sbin/* ${D}${base_sbindir}
  37. rmdir ${D}/sbin
  38. fi
  39. }
  40. # Satisfy the -dev runtime dependency
  41. ALLOW_EMPTY_${PN} = "1"