httpfs2_0.1.5.bb 649 B

12345678910111213141516171819202122232425
  1. SUMMARY = "This is a filesystem client based on the HTTP using FUSE"
  2. HOMEPAGE = "http://httpfs.sourceforge.net"
  3. LICENSE = "GPLv2"
  4. LIC_FILES_CHKSUM = "file://debian/copyright;md5=83f224c5182f148ec92e0b9f84b3c6c7"
  5. inherit pkgconfig
  6. DEPENDS += "fuse"
  7. RDEPENDS_${PN} += "fuse"
  8. SRC_URI += "https://astuteinternet.dl.sourceforge.net/project/httpfs/httpfs2/httpfs2-${PV}.tar.gz"
  9. SRC_URI[sha256sum] = "01cb4bb38deb344f540da6f1464dc7edbdeb51213ad810b8c9c282c1e17e0fc1"
  10. S = "${WORKDIR}/httpfs2-${PV}"
  11. do_compile() {
  12. cd ${S}
  13. oe_runmake httpfs2
  14. }
  15. do_install() {
  16. cd ${S}
  17. install -d ${D}${bindir}
  18. install -m 0755 httpfs2 ${D}${bindir}
  19. }