wvdial_1.61.bb 931 B

12345678910111213141516171819202122232425262728293031
  1. HOMEPAGE = "http://www.alumnit.ca/wiki/?WvDial"
  2. DESCRIPTION = "WvDial is a program that makes it easy to connect your Linux workstation to the Internet."
  3. LICENSE = "LGPLv2"
  4. LIC_FILES_CHKSUM = "file://COPYING.LIB;md5=55ca817ccb7d5b5b66355690e9abc605"
  5. inherit pkgconfig
  6. DEPENDS = "wvstreams"
  7. RDEPENDS_${PN} = "ppp"
  8. SRC_URI = "https://storage.googleapis.com/google-code-archive-downloads/v2/code.google.com/${BPN}/${BP}.tar.bz2 \
  9. file://typo_pon.wvdial.1.patch \
  10. file://musl-support.patch \
  11. "
  12. SRC_URI[md5sum] = "37e9a2d664effe4efd44c0e1a20136de"
  13. SRC_URI[sha256sum] = "99906d9560cbdbc97e1855e7b0a7169f1e11983be3ac539140423f09debced82"
  14. COMPATIBLE_HOST_libc-musl = "null"
  15. EXTRA_OEMAKE = ""
  16. export WVLINK="${LD}"
  17. PARALLEL_MAKE = ""
  18. do_configure() {
  19. sed -i 's/LDFLAGS+=-luniconf/LIBS+=-luniconf/' ${S}/Makefile
  20. }
  21. do_install() {
  22. oe_runmake prefix=${D}/usr PPPDIR=${D}/etc/ppp/peers install
  23. }