pax-utils_1.2.2.bb 1.2 KB

123456789101112131415161718192021222324252627282930313233343536
  1. SUMMARY = "Security-focused ELF files checking tool"
  2. DESCRIPTION = "This is a small set of various PaX aware and related \
  3. utilities for ELF binaries. It can check ELF binary files and running \
  4. processes for issues that might be relevant when using ELF binaries \
  5. along with PaX, such as non-PIC code or executable stack and heap."
  6. HOMEPAGE = "http://www.gentoo.org/proj/en/hardened/pax-utils.xml"
  7. LICENSE = "GPLv2+"
  8. LIC_FILES_CHKSUM = "file://COPYING;md5=eb723b61539feef013de476e68b5c50a"
  9. SRC_URI = "https://dev.gentoo.org/~vapier/dist/pax-utils-${PV}.tar.xz"
  10. SRC_URI[md5sum] = "a580468318f0ff42edf4a8cd314cc942"
  11. SRC_URI[sha256sum] = "7f4a7f8db6b4743adde7582fa48992ad01776796fcde030683732f56221337d9"
  12. RDEPENDS_${PN} += "bash"
  13. export GNULIB_OVERRIDES_WINT_T = "0"
  14. do_configure_prepend() {
  15. touch ${S}/NEWS ${S}/AUTHORS ${S}/ChangeLog ${S}/README
  16. }
  17. do_install() {
  18. oe_runmake PREFIX=${D}${prefix} DESTDIR=${D} install
  19. }
  20. BBCLASSEXTEND = "native"
  21. inherit autotools pkgconfig
  22. PACKAGECONFIG ??= ""
  23. PACKAGECONFIG[libcap] = "--with-caps, --without-caps, libcap"
  24. PACKAGECONFIG[libseccomp] = "--with-seccomp, --without-seccomp, libseccomp"
  25. PACKAGECONFIG[pyelftools] = "--with-python, --without-python,, pyelftools"
  26. EXTRA_OECONF += "--enable-largefile"