libmxml_3.1.bb 1.0 KB

123456789101112131415161718192021222324252627282930313233
  1. DESCRIPTION = "Tiny XML Library"
  2. LICENSE = "Apache-2.0"
  3. LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
  4. HOMEPAGE = "https://www.msweet.org/mxml/"
  5. BUGTRACKER = "https://github.com/michaelrsweet/mxml/issues"
  6. SRC_URI = "git://github.com/michaelrsweet/mxml.git"
  7. SRCREV = "e483e5fd8a33386fd46967681521bdd2da2b548f"
  8. S = "${WORKDIR}/git"
  9. inherit autotools
  10. PACKAGECONFIG ??= "threads"
  11. PACKAGECONFIG[threads] = "--enable-threads,--disable-threads"
  12. # Package does not support out of tree builds.
  13. B = "${S}"
  14. # MXML uses autotools but it explicitly states it does not support autoheader.
  15. EXTRA_AUTORECONF = "--exclude=autopoint,autoheader"
  16. do_configure_prepend() {
  17. # Respect optimization CFLAGS specified by OE.
  18. sed -e 's/-Os -g//' -i ${S}/configure.ac
  19. # Enable verbose compilation output. This is required for extra QA checks to work.
  20. sed -e '/.SILENT:/d' -i ${S}/Makefile.in
  21. }
  22. do_install() {
  23. # Package uses DSTROOT instread of standard DESTDIR to specify install location.
  24. oe_runmake install DSTROOT=${D}
  25. }