logfsprogs_git.bb 1.1 KB

123456789101112131415161718192021222324252627282930
  1. SUMMARY = "LogFS Programs: used to create LogFS file system"
  2. DESCRIPTION = "\
  3. LogFS is a Linux log-structured and scalable flash file system, intended \
  4. for use on large devices of flash memory. It is written by Jörn Engel and \
  5. in part sponsored by the CE Linux Forum. \
  6. LogFS is included in the mainline Linux kernel and was introduced in \
  7. version 2.6.34, released on May 16, 2010."
  8. HOMEPAGE = "https://github.com/prasad-joshi/logfsprogs"
  9. SECTION = "base"
  10. LICENSE = "GPLv2"
  11. LIC_FILES_CHKSUM = "file://fsck.c;md5=3859dc73da97909ff1d0125e88a27e02"
  12. DEPENDS = "zlib"
  13. SRC_URI = "git://github.com/prasad-joshi/logfsprogs.git \
  14. file://0001-Add-LDFLAGS-to-linker-cmdline.patch \
  15. file://0001-btree-Avoid-conflicts-with-libc-namespace-about-setk.patch \
  16. file://0001-include-sys-sysmacros.h-for-major-minor-definition.patch \
  17. "
  18. SRCREV = "45b72c81ce3c6fa17ca19bafc207ea93e76312f4"
  19. S = "${WORKDIR}/git"
  20. EXTRA_OEMAKE = "CC="${CC}" LD="${LD}" AR="${AR}""
  21. do_install () {
  22. mkdir -p ${D}${bindir}
  23. install -m 0755 ${S}/mklogfs ${D}${bindir}/mklogfs
  24. }
  25. BBCLASSEXTEND = "native nativesdk"