nbench-byte_2.2.3.bb 927 B

12345678910111213141516171819202122232425262728
  1. SUMMARY = "A CPU benchmark utility"
  2. DESCRIPTION = "BYTE Magazine's native benchmarks (also called BYTEmark) \
  3. designed to expose the capabilities of a system's CPU, FPU, \
  4. and memory system."
  5. HOMEPAGE = "http://www.tux.org/~mayer/linux/"
  6. LICENSE = "nbench-byte"
  7. LIC_FILES_CHKSUM = "file://README;beginline=57;endline=66;md5=020ef579f8fa5746b7e307a54707834f"
  8. SECTION = "console/utils"
  9. SRC_URI = "https://fossies.org/linux/misc/old/${BP}.tar.gz \
  10. file://nbench_32bits.patch \
  11. file://Makefile-add-more-dependencies-to-pointer.h.patch"
  12. SRC_URI[md5sum] = "285dfab361080759d477ea1fe7d3093a"
  13. SRC_URI[sha256sum] = "723dd073f80e9969639eb577d2af4b540fc29716b6eafdac488d8f5aed9101ac"
  14. EXTRA_OEMAKE = "-e MAKEFLAGS="
  15. TARGET_CC_ARCH += "${LDFLAGS}"
  16. do_compile() {
  17. oe_runmake
  18. }
  19. do_install () {
  20. install -d ${D}${bindir}
  21. install -m 0644 NNET.DAT ${D}${bindir}/
  22. install -m 0755 nbench ${D}${bindir}/
  23. }