libtorrent_git.bb 951 B

1234567891011121314151617181920212223242526272829303132
  1. DESCRIPTION = "libTorrent is a BitTorrent library written in C++ for *nix, \
  2. with a focus on high performance and good code."
  3. HOMEPAGE = "http://libtorrent.rakshasa.no/"
  4. LICENSE = "GPL-2.0"
  5. LIC_FILES_CHKSUM = "file://COPYING;md5=393a5ca445f6965873eca0259a17f833"
  6. DEPENDS = "zlib libsigc++-2.0 openssl cppunit"
  7. SRC_URI = "git://github.com/rakshasa/libtorrent \
  8. file://don-t-run-code-while-configuring-package.patch \
  9. "
  10. SRCREV = "756f70010779927dc0691e1e722ed433d5d295e1"
  11. PV = "0.13.8"
  12. S = "${WORKDIR}/git"
  13. PACKAGECONFIG ??= "instrumentation"
  14. PACKAGECONFIG_remove_mipsarch = "instrumentation"
  15. PACKAGECONFIG_remove_powerpc = "instrumentation"
  16. PACKAGECONFIG_remove_riscv32 = "instrumentation"
  17. PACKAGECONFIG[instrumentation] = "--enable-instrumentation,--disable-instrumentation,"
  18. inherit autotools pkgconfig
  19. EXTRA_OECONF = "--with-zlib=${STAGING_EXECPREFIXDIR}"
  20. do_configure_prepend() {
  21. (cd ${S}; ./autogen.sh; cd -)
  22. }