colord.bb 1.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445
  1. require ${BPN}.inc
  2. inherit meson gobject-introspection gsettings gettext bash-completion systemd features_check useradd
  3. # polkit and gobject-introspection are mandatory and cannot be configured
  4. REQUIRED_DISTRO_FEATURES = "polkit gobject-introspection-data"
  5. UNKNOWN_CONFIGURE_WHITELIST_append = " introspection"
  6. DEPENDS += " \
  7. ${BPN}-native \
  8. glib-2.0 \
  9. lcms \
  10. sqlite3 \
  11. libgusb \
  12. libgudev \
  13. polkit \
  14. "
  15. SRC_URI += " \
  16. file://0001-Run-native-cd_idt8-cd_create_profile.patch \
  17. "
  18. EXTRA_OEMESON = " \
  19. -Dman=false \
  20. -Ddocs=false \
  21. "
  22. PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}"
  23. PACKAGECONFIG[systemd] = "-Dsystemd=true, -Dsystemd=false, systemd"
  24. SYSTEMD_SERVICE_${PN} = "colord.service"
  25. FILES_${PN} += " \
  26. ${datadir}/dbus-1 \
  27. ${datadir}/polkit-1 \
  28. ${datadir}/glib-2.0 \
  29. ${datadir}/color \
  30. ${systemd_user_unitdir} \
  31. ${nonarch_libdir}/tmpfiles.d \
  32. ${libdir}/colord-plugins \
  33. ${libdir}/colord-sensors \
  34. "
  35. USERADD_PACKAGES = "${PN}"
  36. USERADD_PARAM_${PN} = "--system --user-group -d /var/lib/colord -s /bin/false colord"