boinc-client_7.16.bb 3.3 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667686970717273747576777879808182838485868788899091
  1. # Copyright (C) 2016 Khem Raj <raj.khem@gmail.com>
  2. # Released under the MIT license (see COPYING.MIT for the terms)
  3. SUMMARY = "Open-source software for volunteer computing"
  4. DESCRIPTION = "The Berkeley Open Infrastructure for Network Computing (BOINC) is an open- \
  5. source software platform which supports distributed computing, primarily in \
  6. the form of volunteer computing and desktop Grid computing. It is well \
  7. suited for problems which are often described as trivially parallel. BOINC \
  8. is the underlying software used by projects such as SETI@home, Einstein@Home, \
  9. ClimatePrediciton.net, the World Community Grid, and many other distributed \
  10. computing projects. \
  11. This package installs the BOINC client software, which will allow your \
  12. computer to participate in one or more BOINC projects, using your spare \
  13. computer time to search for cures for diseases, model protein folding, study \
  14. global warming, discover sources of gravitational waves, and many other types \
  15. of scientific and mathematical research."
  16. HOMEPAGE = "http://boinc.berkeley.edu/"
  17. LICENSE = "LGPLv2+ & GPLv3"
  18. LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504 \
  19. file://COPYING.LESSER;md5=6a6a8e020838b23406c81b19c1d46df6"
  20. SECTION = "applications"
  21. DEPENDS = "curl \
  22. jpeg \
  23. openssl \
  24. sqlite3 \
  25. virtual/libgl \
  26. ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'libnotify', '', d)} \
  27. ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'gtk+ libnotify xcb-util libxscrnsaver', '', d)} \
  28. nettle \
  29. "
  30. SRCREV = "e0e033af9fca3cca84a3417ea6531ae25be73a7a"
  31. BRANCH = "client_release/7/${PV}"
  32. SRC_URI = "git://github.com/BOINC/boinc;protocol=https;branch=${BRANCH} \
  33. file://boinc-AM_CONDITIONAL.patch \
  34. file://opengl_m4_check.patch \
  35. file://gtk-configure.patch \
  36. "
  37. inherit gettext autotools pkgconfig features_check systemd
  38. REQUIRED_DISTRO_FEATURES += "opengl"
  39. S = "${WORKDIR}/git"
  40. EXTRA_OECONF += "\
  41. --enable-libraries \
  42. --enable-unicode \
  43. --enable-shared \
  44. --enable-dynamic-client-linkage \
  45. --enable-client \
  46. --disable-server \
  47. --disable-static \
  48. --disable-manager \
  49. --with-ssl=${STAGING_EXECPREFIXDIR} \
  50. --without-wxdir \
  51. --without-x \
  52. --with-boinc-platform=${TARGET_SYS} \
  53. "
  54. export PKG_CONFIG = "${STAGING_BINDIR_NATIVE}/pkg-config"
  55. do_configure_prepend () {
  56. if "${@bb.utils.contains('DEPENDS', 'gtk+', '1', '0', d)}" = "0"
  57. then
  58. export GTK2_CFLAGS=""
  59. export GTK2_LIBS=""
  60. fi
  61. }
  62. do_compile_prepend () {
  63. # Disable rpaths
  64. sed -i -e 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' ${B}/${TARGET_SYS}-libtool
  65. sed -i -e 's|^sys_lib_dlsearch_path_spec=.*|sys_lib_dlsearch_path_spec=""|g' ${B}/${TARGET_SYS}-libtool
  66. sed -i -e 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' ${B}/${TARGET_SYS}-libtool
  67. }
  68. do_install_append() {
  69. if [ -e ${D}${nonarch_libdir}/systemd/system/boinc-client.service ]; then
  70. install -d ${D}${systemd_system_unitdir}
  71. mv \
  72. ${D}${nonarch_libdir}/systemd/system/boinc-client.service \
  73. ${D}${systemd_system_unitdir}/boinc-client.service
  74. rmdir --ignore-fail-on-non-empty ${D}${nonarch_libdir}/systemd/system \
  75. ${D}${nonarch_libdir}/systemd \
  76. ${D}${nonarch_libdir}
  77. fi
  78. }
  79. SYSTEMD_SERVICE_${PN} = "boinc-client.service"
  80. FILES_${PN} += "${libdir}/systemd"