apache-websocket_git.bb 1.1 KB

123456789101112131415161718192021222324252627282930313233
  1. SUMMARY = "Websocket module for Apache web server"
  2. DESCRIPTION = "Process requests using the WebSocket protocol (RFC 6455)"
  3. HOMEPAGE = "https://github.com/jchampio/apache-websocket/"
  4. SECTION = "net"
  5. LICENSE = "Apache-2.0"
  6. inherit autotools-brokensep pkgconfig
  7. DEPENDS = "apache2 apache2-native pbzip2-native"
  8. RDEPENDS_${PN} += "apache2"
  9. # Original (github.com/disconnect/apache-websocket) is dead since 2012, the
  10. # fork contains patches from the modules ML and fixes CVE compliance issues
  11. SRC_URI = "git://github.com/jchampio/apache-websocket.git"
  12. SRCREV = "0ee34c77fc78ff08fd548706300b80a7bc7874e4"
  13. PV = "0.1.2+git${SRCPV}"
  14. S = "${WORKDIR}/git"
  15. LIC_FILES_CHKSUM = "file://LICENSE;md5=2ee41112a44fe7014dce33e26468ba93"
  16. EXTRA_OECONF = "APACHECTL=${STAGING_DIR_TARGET}${sbindir}/apachectl \
  17. LIBTOOL=${STAGING_DIR_TARGET}${bindir_crossscripts}/${HOST_SYS}-libtool"
  18. do_install() {
  19. install -d ${D}${libexecdir}/apache2/modules
  20. install -m 755 ${B}/.libs/mod_websocket.so ${D}${libexecdir}/apache2/modules
  21. }
  22. FILES_${PN} += " ${libexecdir}/apache2/modules/* "
  23. FILES_${PN}-dbg += " ${libexecdir}/apache2/modules/.debug/* "