mysql-python_1.2.5.bb 846 B

123456789101112131415161718192021222324
  1. SUMMARY = "Python interface to MySQL"
  2. HOMEPAGE = "https://github.com/farcepest/MySQLdb1"
  3. SECTION = "devel/python"
  4. LICENSE = "GPLv2"
  5. LIC_FILES_CHKSUM = "file://GPL-2.0;md5=b234ee4d69f5fce4486a80fdaf4a4263"
  6. DEPENDS = "mysql5"
  7. SRCNAME = "MySQL-python"
  8. SRC_URI = "https://pypi.python.org/packages/source/M/${SRCNAME}/${SRCNAME}-${PV}.zip \
  9. file://0001-_mysql.c-fix-compilation-with-MariaDB-with-10.3.13.patch \
  10. "
  11. SRC_URI[md5sum] = "654f75b302db6ed8dc5a898c625e030c"
  12. SRC_URI[sha256sum] = "811040b647e5d5686f84db415efd697e6250008b112b6909ba77ac059e140c74"
  13. S = "${WORKDIR}/${SRCNAME}-${PV}"
  14. inherit ${@bb.utils.contains("BBFILE_COLLECTIONS", "meta-python2", "setuptools", "", d)}
  15. python() {
  16. if 'meta-python2' not in d.getVar('BBFILE_COLLECTIONS').split():
  17. raise bb.parse.SkipRecipe('Requires meta-python2 to be present.')
  18. }