bluez4_4.101.bb 1.8 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950
  1. require bluez4.inc
  2. PNBLACKLIST[bluez4] ?= "${@bb.utils.contains('DISTRO_FEATURES', 'bluez5', 'bluez5 conflicts with bluez4 and bluez5 is selected in DISTRO_FEATURES', '', d)}"
  3. PR = "r11"
  4. SRC_URI += "file://bluetooth.conf \
  5. file://sbc_mmx.patch \
  6. file://fix-udev-paths.patch \
  7. file://obsolete_automake_macros.patch \
  8. file://network-fix-network-Connect-method-parameters.patch \
  9. file://install-test-script.patch \
  10. file://fix_encrypt_collision.patch \
  11. "
  12. SRC_URI[md5sum] = "fb42cb7038c380eb0e2fa208987c96ad"
  13. SRC_URI[sha256sum] = "59738410ade9f0e61a13c0f77d9aaffaafe49ba9418107e4ad75fe52846f7487"
  14. RCONFLICTS_${PN} = "bluez5"
  15. do_install_append() {
  16. install -m 0644 ${S}/audio/audio.conf ${D}/${sysconfdir}/bluetooth/
  17. install -m 0644 ${S}/network/network.conf ${D}/${sysconfdir}/bluetooth/
  18. install -m 0644 ${S}/input/input.conf ${D}/${sysconfdir}/bluetooth/
  19. # at_console doesn't really work with the current state of OE, so punch some more holes so people can actually use BT
  20. install -m 0644 ${WORKDIR}/bluetooth.conf ${D}/${sysconfdir}/dbus-1/system.d/
  21. }
  22. RDEPENDS_${PN}-dev = "bluez-hcidump"
  23. RDEPENDS_${PN}-testtools += "python python-dbus python-pygobject"
  24. ALLOW_EMPTY_libasound-module-bluez = "1"
  25. PACKAGES =+ "libasound-module-bluez ${PN}-testtools"
  26. FILES_libasound-module-bluez = "${libdir}/alsa-lib/lib*.so ${datadir}/alsa"
  27. FILES_${PN} += "${libdir}/bluetooth/plugins ${libdir}/bluetooth/plugins/*.so ${base_libdir}/udev/ ${nonarch_base_libdir}/udev/ ${systemd_unitdir}/ ${datadir}/dbus-1"
  28. FILES_${PN}-dev += "\
  29. ${libdir}/bluetooth/plugins/*.la \
  30. ${libdir}/alsa-lib/*.la \
  31. "
  32. FILES_${PN}-testtools = "${libdir}/bluez4/test/*"
  33. FILES_${PN}-dbg += "\
  34. ${libdir}/bluetooth/plugins/.debug \
  35. ${libdir}/*/.debug \
  36. */udev/.debug \
  37. "
  38. SYSTEMD_SERVICE_${PN} = "bluetooth.service"