bpftool.bb 904 B

123456789101112131415161718192021222324252627282930313233
  1. SUMMARY = "Inspect and manipulate eBPF programs and maps"
  2. DESCRIPTION = "bpftool is a kernel tool for inspection and simple manipulation \
  3. of eBPF programs and maps."
  4. LICENSE = "GPLv2"
  5. LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
  6. DEPENDS = "binutils elfutils"
  7. PROVIDES = "virtual/bpftool"
  8. inherit bash-completion kernelsrc kernel-arch
  9. do_populate_lic[depends] += "virtual/kernel:do_patch"
  10. EXTRA_OEMAKE = "-C ${S}/tools/bpf/bpftool O=${B} CROSS=${TARGET_PREFIX} CC="${CC}" LD="${LD}" AR=${AR} ARCH=${ARCH}"
  11. do_configure[depends] += "virtual/kernel:do_shared_workdir"
  12. COMPATIBLE_HOST_libc-musl = 'null'
  13. do_compile() {
  14. oe_runmake
  15. }
  16. do_install() {
  17. oe_runmake DESTDIR=${D} install
  18. }
  19. PACKAGE_ARCH = "${MACHINE_ARCH}"
  20. python do_package_prepend() {
  21. d.setVar('PKGV', d.getVar("KERNEL_VERSION").split("-")[0])
  22. }
  23. B = "${WORKDIR}/${BPN}-${PV}"