libio-socket-ssl-perl_2.068.bb 1.6 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647
  1. SUMMARY = "Perl library for transparent SSL"
  2. DESCRIPTION = "This module is a true drop-in replacement for IO::Socket::INET that \
  3. uses SSL to encrypt data before it is transferred to a remote server \
  4. or client. IO::Socket::SSL supports all the extra features that one \
  5. needs to write a full-featured SSL client or server application: \
  6. multiple SSL contexts, cipher selection, certificate verification, and \
  7. SSL version selection. As an extra bonus, it works perfectly with \
  8. mod_perl."
  9. HOMEPAGE = "http://search.cpan.org/dist/IO-Socket-SSL/"
  10. SECTION = "libs"
  11. LICENSE = "Artistic-1.0|GPLv1+"
  12. LIC_FILES_CHKSUM = "file://META.yml;beginline=12;endline=12;md5=963ce28228347875ace682de56eef8e8"
  13. RDEPENDS_${PN} += "\
  14. libnet-ssleay-perl \
  15. perl-module-autoloader \
  16. perl-module-scalar-util \
  17. perl-module-io-socket \
  18. "
  19. SRC_URI = "http://search.cpan.org/CPAN/authors/id/S/SU/SULLR/IO-Socket-SSL-${PV}.tar.gz \
  20. file://run-ptest \
  21. "
  22. SRC_URI[md5sum] = "4230c829c8875889848093b2b46a7284"
  23. SRC_URI[sha256sum] = "4420fc0056f1827b4dd1245eacca0da56e2182b4ef6fc078f107dc43c3fb8ff9"
  24. S = "${WORKDIR}/IO-Socket-SSL-${PV}"
  25. inherit cpan ptest
  26. do_install_append () {
  27. mkdir -p ${D}${docdir}/${PN}/
  28. cp ${S}/BUGS ${D}${docdir}/${PN}/
  29. cp ${S}/Changes ${D}${docdir}/${PN}/
  30. cp ${S}/README ${D}${docdir}/${PN}/
  31. cp -pRP ${S}/docs ${D}${docdir}/${PN}/
  32. cp -pRP ${S}/certs ${D}${docdir}/${PN}/
  33. cp -pRP ${S}/example ${D}${docdir}/${PN}/
  34. }
  35. do_install_ptest () {
  36. cp -r ${B}/t ${D}${PTEST_PATH}
  37. cp -r ${B}/certs ${D}${PTEST_PATH}
  38. }
  39. BBCLASSEXTEND = "native"