python3-pyparted_3.11.7.bb 837 B

12345678910111213141516171819202122232425
  1. DESCRIPTION = "pyparted is a set of Python modules that provide Python programmers \
  2. an interface to libparted, the GNU parted library for disk partitioning and \
  3. filesystem manipulation."
  4. SUMMARY = "Python bindings for libparted"
  5. HOMEPAGE = "https://github.com/rhinstaller/pyparted"
  6. LICENSE = "GPL-2.0+"
  7. LIC_FILES_CHKSUM = "\
  8. file://COPYING;md5=8ca43cbc842c2336e835926c2166c28b \
  9. file://src/_pedmodule.c;beginline=10;endline=22;md5=9e53304db812b80d0939e11bb69dcab2 \
  10. "
  11. SRC_URI[md5sum] = "69284f943982f54ded76960c92098a02"
  12. SRC_URI[sha256sum] = "61cde7b096bccd69ddc75c85b17f8baed45c3687d404706d91403a319453b903"
  13. inherit pypi distutils3
  14. DEPENDS += "parted"
  15. RDEPENDS_${PN}_class-target += " \
  16. parted (>= 2.3) \
  17. python3-stringold python3-codecs python3-math \
  18. "
  19. RDEPENDS_${PN}_class-native = ""
  20. BBCLASSEXTEND = "native"