iwd_1.10.bb 1.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354
  1. SUMMARY = "Wireless daemon for Linux"
  2. HOMEPAGE = "https://iwd.wiki.kernel.org/"
  3. LICENSE = "LGPL-2.1"
  4. LIC_FILES_CHKSUM = "file://COPYING;md5=fb504b67c50331fc78734fed90fb0e09"
  5. DEPENDS = "ell"
  6. SRC_URI = "git://git.kernel.org/pub/scm/network/wireless/iwd.git"
  7. SRCREV = "d8dc5a9bd19c5b98d8692801d3cf4e8af495930a"
  8. S = "${WORKDIR}/git"
  9. inherit autotools manpages pkgconfig python3native systemd
  10. PACKAGECONFIG ??= " \
  11. client \
  12. monitor \
  13. ${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)} \
  14. "
  15. PACKAGECONFIG[client] = "--enable-client,--disable-client,readline"
  16. PACKAGECONFIG[monitor] = "--enable-monitor,--disable-monitor"
  17. PACKAGECONFIG[manpages] = "--enable-manual-pages,--disable-manual-pages,python3-docutils-native"
  18. PACKAGECONFIG[wired] = "--enable-wired,--disable-wired"
  19. PACKAGECONFIG[ofono] = "--enable-ofono,--disable-ofono"
  20. PACKAGECONFIG[systemd] = "--with-systemd-unitdir=${systemd_system_unitdir},--disable-systemd-service,systemd"
  21. EXTRA_OECONF = "--enable-external-ell"
  22. SYSTEMD_SERVICE_${PN} = " \
  23. iwd.service \
  24. ${@bb.utils.contains('PACKAGECONFIG', 'wired', 'ead.service', '', d)} \
  25. "
  26. do_configure_prepend() {
  27. install -d ${S}/build-aux
  28. }
  29. do_install_append() {
  30. # If client and monitor are disabled, bindir is empty, causing a QA error
  31. rmdir --ignore-fail-on-non-empty ${D}/${bindir}
  32. }
  33. FILES_${PN} += " \
  34. ${datadir}/dbus-1 \
  35. ${nonarch_libdir}/modules-load.d \
  36. ${systemd_unitdir}/network \
  37. "
  38. RDEPENDS_${PN} = "dbus"
  39. RRECOMMENDS_${PN} = "\
  40. kernel-module-pkcs7-message \
  41. kernel-module-pkcs8-key-parser \
  42. kernel-module-x509-key-parser \
  43. "