libblockdev_2.24.bb 2.1 KB

12345678910111213141516171819202122232425262728293031323334353637383940
  1. DESCRIPTION = "libblockdev is a C library supporting GObject introspection for manipulation of \
  2. block devices. It has a plugin-based architecture where each technology (like \
  3. LVM, Btrfs, MD RAID, Swap,...) is implemented in a separate plugin, possibly \
  4. with multiple implementations (e.g. using LVM CLI or the new LVM DBus API)."
  5. HOMEPAGE = "http://rhinstaller.github.io/libblockdev/"
  6. LICENSE = "LGPLv2+"
  7. SECTION = "devel/lib"
  8. LIC_FILES_CHKSUM = "file://LICENSE;md5=c07cb499d259452f324bb90c3067d85c"
  9. inherit autotools gobject-introspection
  10. SRC_URI = "git://github.com/storaged-project/libblockdev;branch=2.x-branch"
  11. SRCREV = "f5a4ba8bb298f8cbc435707d0b19b4b2ff836a8e"
  12. S = "${WORKDIR}/git"
  13. FILES_${PN} += "${libdir}/python2.7/dist-packages ${libdir}/python3.*/site-packages"
  14. PACKAGECONFIG ??= "python3 lvm dm kmod parted fs escrow btrfs crypto mdraid kbd mpath nvdimm"
  15. PACKAGECONFIG[python3] = "--with-python3, --without-python3,,python3"
  16. PACKAGECONFIG[python2] = "--with-python2, --without-python2,,python"
  17. PACKAGECONFIG[lvm] = "--with-lvm, --without-lvm, multipath-tools, lvm2"
  18. PACKAGECONFIG[lvm-dbus] = "--with-lvm_dbus, --without-lvm_dbus, multipath-tools, lvm2"
  19. PACKAGECONFIG[dm] = "--with-dm, --without-dm, multipath-tools, lvm2"
  20. PACKAGECONFIG[dmraid] = "--with-dmraid, --without-dmraid"
  21. PACKAGECONFIG[kmod] = "--with-kbd, --without-kbd, kmod"
  22. PACKAGECONFIG[parted] = "--with-part, --without-part, parted"
  23. PACKAGECONFIG[fs] = "--with-fs, --without-fs, util-linux"
  24. PACKAGECONFIG[doc] = "--with-gtk-doc, --without-gtk-doc, gtk-doc-native"
  25. PACKAGECONFIG[nvdimm] = "--with-nvdimm, --without-nvdimm, ndctl util-linux"
  26. PACKAGECONFIG[vdo] = "--with-vdo, --without-vdo"
  27. PACKAGECONFIG[escrow] = "--with-escrow, --without-escrow, nss volume-key"
  28. PACKAGECONFIG[btrfs] = "--with-btrfs,--without-btrfs,libbytesize btrfs-tools"
  29. PACKAGECONFIG[crypto] = "--with-crypto,--without-crypto,cryptsetup nss volume-key"
  30. PACKAGECONFIG[mdraid] = "--with-mdraid,--without-mdraid,libbytesize"
  31. PACKAGECONFIG[kbd] = "--with-kbd,--without-kbd,libbytesize"
  32. PACKAGECONFIG[mpath] = "--with-mpath,--without-mpath, multipath-tools, lvm2"
  33. export GIR_EXTRA_LIBS_PATH="${B}/src/utils/.libs"