satyr_0.35.bb 952 B

1234567891011121314151617181920212223242526272829303132333435
  1. DESCRIPTION = "Satyr is a collection of low-level algorithms for program \
  2. failure processing, analysis, and reporting supporting kernel space, user \
  3. space, Python, and Java programs"
  4. HOMEPAGE = "https://github.com/abrt/satyr"
  5. LICENSE = "GPLv2"
  6. inherit autotools-brokensep python3native pkgconfig
  7. SRC_URI = "git://github.com/abrt/satyr.git \
  8. file://0002-fix-compile-failure-against-musl-C-library.patch \
  9. "
  10. SRCREV = "8690a1f83adc5a7a83e856ebc7adf6310bbd3b9f"
  11. S = "${WORKDIR}/git"
  12. LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
  13. DEPENDS += " \
  14. gdb \
  15. gperf-native \
  16. json-c \
  17. nettle \
  18. glib-2.0 \
  19. "
  20. PACKAGES += "python3-${BPN}"
  21. FILES_python3-${BPN} = "${PYTHON_SITEPACKAGES_DIR}/${BPN}"
  22. PACKAGECONFIG ??= "python3 rpm"
  23. PACKAGECONFIG[python3] = "--with-python3, --without-python3,,python3"
  24. PACKAGECONFIG[rpm] = "--with-rpm, --without-rpm, rpm"
  25. do_configure_prepend() {
  26. ${S}/gen-version
  27. }