gnome-bluetooth_2.32.0.bb 1.3 KB

12345678910111213141516171819202122232425262728293031323334353637
  1. SUMMARY = "GNOME bluetooth manager"
  2. LICENSE = "GPLv2 & LGPLv2.1"
  3. LIC_FILES_CHKSUM = "file://COPYING;md5=eb723b61539feef013de476e68b5c50a \
  4. file://COPYING.LIB;md5=a6f89e2100d9b6cdffcea4f398e37343 \
  5. "
  6. PR = "r1"
  7. SECTION = "x11/gnome"
  8. DEPENDS = "obexd gnome-doc-utils-native gnome-doc-utils gconf gtk+ dbus-glib libunique libnotify gnome-keyring virtual/libx11 libxi intltool-native"
  9. DEPENDS += "${@bb.utils.contains('DISTRO_FEATURES','bluez5','bluez5','bluez4',d)}"
  10. inherit gnomebase gtk-icon-cache
  11. SRC_URI += " \
  12. file://0001-bluetooth-input-Fix-compile-errors.patch \
  13. file://0002-bluetooth-client-use-valid-interface-names.patch \
  14. "
  15. SRC_URI[archive.md5sum] = "f129686fe46c4c98eb70a0cc85d59cae"
  16. SRC_URI[archive.sha256sum] = "57b1f06c96a1b85e1c19ff919d708cc38e95edae658881ed99968c325839a973"
  17. GNOME_COMPRESS_TYPE="bz2"
  18. # No 'nautilus-sendto' recipe in meta-gnome yet
  19. EXTRA_OECONF += "--enable-nautilus-sendto=no"
  20. # No native docbook XSL stylesheets recipe in OE yet
  21. do_configure_prepend() {
  22. sed -i s/help// ${S}/Makefile.am
  23. }
  24. do_configure_append() {
  25. sed -i 's,func_fatal_error "error: cannot install,echo "bogus message about,' ${HOST_SYS}-libtool
  26. }
  27. RRECOMMENDS_${PN} += "obexd obex-data-server"
  28. FILES_${PN}-dbg += "${libdir}/gnome-bluetooth/plugins/.debug/"