rest_0.8.1.bb 1.1 KB

123456789101112131415161718192021222324252627282930313233
  1. SUMMARY = "library to access web services that claim to be "RESTful""
  2. HOMEPAGE = "https://wiki.gnome.org/Projects/Librest"
  3. LICENSE = "LGPLv2.1"
  4. LIC_FILES_CHKSUM = "file://COPYING;md5=2d5025d4aa3495befef8f17206a5b0a1"
  5. GNOMEBASEBUILDCLASS = "autotools"
  6. DEPENDS = " \
  7. libxml2-native \
  8. glib-2.0-native \
  9. glib-2.0 \
  10. libsoup-2.4 \
  11. "
  12. inherit gnomebase gobject-introspection gtk-doc vala
  13. SRC_URI[archive.md5sum] = "ece4547298a81105f307369d73c21b9d"
  14. SRC_URI[archive.sha256sum] = "0513aad38e5d3cedd4ae3c551634e3be1b9baaa79775e53b2dba9456f15b01c9"
  15. # * gnome environment requires libsoup build with in gnome PACKAGECONFIG
  16. # * libsoup-gnome support was removed upstream three years ago [1]
  17. # [1] https://gitlab.gnome.org/GNOME/librest/commit/8f904a8e2bb38a7bf72245cdf2f1ecad17e9a720
  18. EXTRA_OECONF = "--without-gnome"
  19. do_configure_prepend() {
  20. # rest expects introspection.m4 at custom location (see aclocal.m4).
  21. cp -f ${STAGING_DIR_TARGET}/${datadir}/aclocal/introspection.m4 ${S}/build
  22. }
  23. do_compile_prepend() {
  24. export GIR_EXTRA_LIBS_PATH="${B}/rest/.libs"
  25. }