libusb-compat_0.1.7.bb 1.3 KB

1234567891011121314151617181920212223242526272829303132333435363738394041
  1. SUMMARY = "libusb-0.1 compatibility layer for libusb1"
  2. DESCRIPTION = "libusb-0.1 compatible layer for libusb1, a drop-in replacement \
  3. that aims to look, feel and behave exactly like libusb-0.1"
  4. HOMEPAGE = "http://www.libusb.org/"
  5. BUGTRACKER = "http://www.libusb.org/report"
  6. SECTION = "libs"
  7. LICENSE = "LGPLv2.1+"
  8. LIC_FILES_CHKSUM = "file://LICENSE;md5=f2ac5f3ac4835e8f91324a26a590a423"
  9. DEPENDS = "libusb1"
  10. # Few packages are known not to work with libusb-compat (e.g. libmtp-1.0.0),
  11. # so here libusb-0.1 is removed completely instead of adding virtual/libusb0.
  12. # Besides, libusb-0.1 uses a per 1ms polling that hurts a lot to power
  13. # consumption.
  14. PROVIDES = "libusb virtual/libusb0"
  15. BBCLASSEXTEND = "native nativesdk"
  16. PE = "1"
  17. SRC_URI = " \
  18. git://github.com/libusb/libusb-compat-0.1.git;protocol=https \
  19. file://0001-usb.h-Include-sys-types.h.patch \
  20. "
  21. SRCREV = "4a27760ec5954ec8605e052a3207afbe0979eeef"
  22. S = "${WORKDIR}/git"
  23. UPSTREAM_CHECK_URI = "https://github.com/libusb/libusb-compat-0.1/releases"
  24. BINCONFIG = "${bindir}/libusb-config"
  25. inherit autotools pkgconfig binconfig-disabled lib_package
  26. EXTRA_OECONF = "--libdir=${base_libdir}"
  27. do_install_append() {
  28. install -d ${D}${libdir}
  29. if [ ! ${D}${libdir} -ef ${D}${base_libdir} ]; then
  30. mv ${D}${base_libdir}/pkgconfig ${D}${libdir}
  31. fi
  32. }