vlc_3.0.11.bb 5.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134
  1. DESCRIPTION = "Video player and streamer - davinci edition"
  2. HOMEPAGE = "http://www.videolan.org"
  3. SECTION = "multimedia"
  4. LICENSE = "GPL-2.0"
  5. LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
  6. DEPENDS = "coreutils-native fribidi libtool libgcrypt libgcrypt-native \
  7. dbus libxml2 gnutls \
  8. tremor faad2 ffmpeg flac alsa-lib \
  9. lua-native lua libidn \
  10. avahi jpeg xz libmodplug mpeg2dec \
  11. libmtp libopus orc libsamplerate0 libusb1 schroedinger taglib \
  12. tiff"
  13. LDFLAGS_append_riscv64 = " -latomic"
  14. # While this item does not require it, it depends on ffmpeg which does
  15. LICENSE_FLAGS = "commercial"
  16. SRC_URI = "http://download.videolan.org/pub/videolan/${BPN}/${PV}/${BP}.tar.xz \
  17. file://0001-make-opencv-configurable.patch \
  18. file://0002-use-vorbisidec.patch \
  19. file://0003-fix-luaL-checkint.patch \
  20. file://0004-Use-packageconfig-to-detect-mmal-support.patch \
  21. file://0005-Fix-build-with-Qt-5.15.patch \
  22. "
  23. SRC_URI[sha256sum] = "3e94a1acf33445e9da15d528aa48657aa26b912eaa2656b403d43860a8834919"
  24. inherit autotools features_check gettext pkgconfig mime-xdg
  25. REQUIRED_DISTRO_FEATURES = "x11"
  26. export BUILDCC = "${BUILD_CC}"
  27. EXTRA_OECONF = "\
  28. --enable-run-as-root \
  29. --enable-xvideo \
  30. --disable-screen --disable-caca \
  31. --enable-vlm \
  32. --enable-freetype \
  33. --enable-tremor \
  34. --enable-v4l2 --disable-aa --disable-faad \
  35. --enable-dbus \
  36. --without-contrib \
  37. --without-kde-solid \
  38. --enable-realrtsp \
  39. --disable-libtar \
  40. --enable-avcodec \
  41. ac_cv_path_MOC=${STAGING_BINDIR_NATIVE}${QT_DIR_NAME}/moc \
  42. ac_cv_path_RCC=${STAGING_BINDIR_NATIVE}${QT_DIR_NAME}/rcc \
  43. ac_cv_path_UIC=${STAGING_BINDIR_NATIVE}${QT_DIR_NAME}/uic \
  44. "
  45. PACKAGECONFIG ?= " \
  46. live555 dc1394 dv1394 notify fontconfig fluidsynth freetype dvdread png \
  47. ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11', '', d)} \
  48. x264 \
  49. "
  50. inherit ${@bb.utils.contains('PACKAGECONFIG', 'qt5', 'qmake5_paths', '', d)}
  51. PACKAGECONFIG[mmal] = "--enable-omxil --enable-omxil-vout --enable-rpi-omxil --enable-mmal,,userland"
  52. PACKAGECONFIG[x264] = "--enable-x264,--disable-x264,x264"
  53. PACKAGECONFIG[fluidsynth] = ",,fluidsynth"
  54. PACKAGECONFIG[mad] = "--enable-mad,--disable-mad,libmad"
  55. PACKAGECONFIG[a52] = "--enable-a52,--disable-a52,liba52"
  56. PACKAGECONFIG[jack] = "--enable-jack,--disable-jack,jack"
  57. PACKAGECONFIG[live555] = "--enable-live555 LIVE555_PREFIX=${STAGING_DIR_HOST}${prefix},--disable-live555,live555"
  58. PACKAGECONFIG[libass] = "--enable-libass,--disable-libass,libass"
  59. PACKAGECONFIG[postproc] = "--enable-postproc,--disable-postproc,libpostproc"
  60. PACKAGECONFIG[libva] = "--enable-libva,--disable-libva,libva"
  61. PACKAGECONFIG[opencv] = "--enable-opencv,--disable-opencv,opencv"
  62. PACKAGECONFIG[speex] = "--enable-speex,--disable-speex,speex"
  63. PACKAGECONFIG[gstreamer] = "--enable-gst-decode,--disable-gst-decode,gstreamer1.0 gstreamer1.0-plugins-base gstreamer1.0-plugins-bad"
  64. PACKAGECONFIG[vpx] = "--enable-vpx,--disable-vpx, libvpx"
  65. PACKAGECONFIG[qt5] = "--enable-qt,--disable-qt, qtbase-native qtx11extras qtsvg"
  66. PACKAGECONFIG[freerdp] = "--enable-freerdp,--disable-freerdp, freerdp"
  67. PACKAGECONFIG[dvbpsi] = "--enable-dvbpsi,--disable-dvbpsi, libdvbpsi"
  68. PACKAGECONFIG[samba] = "--enable-smbclient,--disable-smbclient, samba"
  69. PACKAGECONFIG[upnp] = "--enable-upnp,--disable-upnp,libupnp"
  70. PACKAGECONFIG[dvdnav] = "--enable-dvdnav,--disable-dvdnav,libdvdnav libdvdcss"
  71. PACKAGECONFIG[sftp] = "--enable-sftp,--disable-sftp,libssh2"
  72. PACKAGECONFIG[vorbis] = "--enable-vorbis,--disable-vorbis,libvorbis libogg"
  73. PACKAGECONFIG[ogg] = "--enable-ogg,--disable-ogg,libvorbis libogg"
  74. PACKAGECONFIG[dc1394] = "--enable-dc1394,--disable-dc1394,libdc1394"
  75. PACKAGECONFIG[dv1394] = "--enable-dv1394,--disable-dv1394,libraw1394 libavc1394"
  76. PACKAGECONFIG[svg] = "--enable-svg,--disable-svg,librsvg"
  77. PACKAGECONFIG[svgdec] = "--enable-svgdec,--disable-svgdec,librsvg cairo"
  78. PACKAGECONFIG[notify] = "--enable-notify,--disable-notify, libnotify gtk+3"
  79. PACKAGECONFIG[fontconfig] = "--enable-fontconfig,--disable-fontconfig, fontconfig"
  80. PACKAGECONFIG[freetype] = "--enable-freetype,--disable-freetype, freetype"
  81. PACKAGECONFIG[dvdread] = "--enable-dvdread,--disable-dvdread, libdvdread libdvdcss"
  82. PACKAGECONFIG[vnc] = "--enable-vnc,--disable-vnc, libvncserver"
  83. PACKAGECONFIG[x11] = "--with-x --enable-xcb,--without-x --disable-xcb, xcb-util-keysyms libxpm libxinerama"
  84. PACKAGECONFIG[png] = "--enable-png,--disable-png,libpng"
  85. PACKAGECONFIG[vdpau] = "--enable-vdpau,--disable-vdpau,libvdpau"
  86. PACKAGECONFIG[wayland] = "--enable-wayland,--disable-wayland,wayland wayland-native"
  87. do_configure_append() {
  88. sed -i -e s:'${top_builddir_slash}libtool':'${top_builddir_slash}'${TARGET_SYS}-libtool:g ${B}/doltlibtool
  89. # moc needs support: precreate build paths
  90. for qtpath in adapters components/epg components/playlist components/sout dialogs managers styles util/buttons; do
  91. mkdir -p "${B}/modules/gui/qt/$qtpath"
  92. done
  93. }
  94. # This recipe packages vlc as a library as well, so qt4 dependencies
  95. # can be avoided when only the library is installed.
  96. PACKAGES =+ "libvlc"
  97. LEAD_SONAME_libvlc = "libvlc.so.5"
  98. FILES_libvlc = "${libdir}/lib*.so.*"
  99. FILES_${PN} += "\
  100. ${bindir}/vlc \
  101. ${libdir}/vlc/vlc/libvlc_vdpau.so \
  102. ${datadir}/applications \
  103. ${datadir}/vlc/ \
  104. ${datadir}/icons \
  105. ${datadir}/metainfo/vlc.appdata.xml \
  106. "
  107. FILES_${PN}-dbg += "\
  108. ${libdir}/vlc/*/.debug \
  109. ${libdir}/vlc/plugins/*/.debug \
  110. "
  111. FILES_${PN}-staticdev += "\
  112. ${libdir}/vlc/plugins/*/*.a \
  113. "
  114. INSANE_SKIP_${PN} = "dev-so"