libimport-into-perl_1.002004.bb 1.1 KB

1234567891011121314151617181920212223242526272829303132
  1. SUMMARY = "Import::Into - import packages into other packages"
  2. DESCRIPTION = "Writing exporters is a pain. Some use \"Exporter\", some use \
  3. \"Sub::Exporter\", some use \"Moose::Exporter\", some use \
  4. \"Exporter::Declare\"... and some things are pragmas.\
  5. \
  6. Exporting on someone else's behalf is harder. The exporters don't provide a \
  7. consistent API for this, and pragmas need to have their import method called \
  8. directly, since they effect the current unit of compilation. \
  9. \
  10. \"Import::Into\" provides global methods to make this painless."
  11. SECTION = "libs"
  12. HOMEPAGE = "https://metacpan.org/pod/Import-Into/"
  13. LICENSE = "Artistic-1.0 | GPL-1.0+"
  14. LIC_FILES_CHKSUM = "file://README;beginline=209;endline=223;md5=3cf363f1e405dea6db2c6cd0ef23680c"
  15. SRC_URI = "${CPAN_MIRROR}/authors/id/E/ET/ETHER/Import-Into-${PV}.tar.gz"
  16. SRC_URI[md5sum] = "70f2f3b08a5b706ee382a8448c346cb1"
  17. SRC_URI[sha256sum] = "decb259bc2ff015fe3dac85e4a287d4128e9b0506a0b2c5fa7244836a68b1084"
  18. S = "${WORKDIR}/Import-Into-${PV}"
  19. inherit cpan
  20. RDEPENDS_${PN} = " libmodule-runtime-perl \
  21. perl-module-strict \
  22. perl-module-warnings \
  23. "
  24. BBCLASSEXTEND = "native"