crash_7.2.6.bb 4.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120
  1. SUMMARY = "Kernel analysis utility for live systems, netdump, diskdump, kdump, LKCD or mcore dumpfiles"
  2. DESCRIPTION = "The core analysis suite is a self-contained tool that can be used to\
  3. investigate either live systems, kernel core dumps created from the\
  4. netdump, diskdump and kdump packages from Red Hat Linux, the mcore kernel patch\
  5. offered by Mission Critical Linux, or the LKCD kernel patch."
  6. HOMEPAGE = "http://people.redhat.com/anderson"
  7. SECTION = "devel"
  8. LICENSE = "GPLv3"
  9. LIC_FILES_CHKSUM = "file://COPYING3;md5=d32239bcb673463ab874e80d47fae504"
  10. DEPENDS = "zlib readline coreutils-native"
  11. S = "${WORKDIR}/git"
  12. SRC_URI = "git://github.com/crash-utility/${BPN}.git \
  13. ${GNU_MIRROR}/gdb/gdb-7.6.tar.gz;name=gdb;subdir=git \
  14. file://7001force_define_architecture.patch \
  15. file://7003cross_ranlib.patch \
  16. file://0001-cross_add_configure_option.patch \
  17. file://sim-ppc-drop-LIBS-from-psim-dependency.patch \
  18. file://sim-common-sim-arange-fix-extern-inline-handling.patch \
  19. file://donnot-extract-gdb-during-do-compile.patch \
  20. file://gdb_build_jobs_and_not_write_crash_target.patch \
  21. file://remove-unrecognized-gcc-option-m32-for-mips.patch \
  22. file://0002-crash-fix-build-error-unknown-type-name-gdb_fpregset.patch \
  23. file://0003-crash-detect-the-sysroot-s-glibc-header-file.patch \
  24. "
  25. SRCREV = "4076ebea6626e3f0a20150602c6ffab999ea5c90"
  26. SRC_URI[gdb.md5sum] = "a9836707337e5f7bf76a009a8904f470"
  27. SRC_URI[gdb.sha256sum] = "8070389a5dcc104eb0be483d582729f98ed4d761ad19cedd3f17b5d2502faa36"
  28. UPSTREAM_CHECK_URI = "https://github.com/crash-utility/crash/releases"
  29. inherit gettext
  30. BBCLASSEXTEND = "native cross"
  31. TARGET_CC_ARCH_append = " ${SELECTED_OPTIMIZATION}"
  32. # crash 7.1.3 and before don't support mips64
  33. COMPATIBLE_HOST = "^(?!mips64).*"
  34. EXTRA_OEMAKE = 'RPMPKG="${PV}" \
  35. GDB_TARGET="${TARGET_SYS}" \
  36. GDB_HOST="${BUILD_SYS}" \
  37. GDB_MAKE_JOBS="${PARALLEL_MAKE}" \
  38. LDFLAGS="${LDFLAGS}" \
  39. '
  40. EXTRA_OEMAKE_class-cross = 'RPMPKG="${PV}" \
  41. GDB_TARGET="${BUILD_SYS} \
  42. \${GDB_CONF_FLAGS} \
  43. --target=${TARGET_SYS}" \
  44. GDB_HOST="${BUILD_SYS}" \
  45. GDB_MAKE_JOBS="${PARALLEL_MAKE}" \
  46. '
  47. EXTRA_OEMAKE_append_class-native = " LDFLAGS='${BUILD_LDFLAGS}'"
  48. EXTRA_OEMAKE_append_class-cross = " LDFLAGS='${BUILD_LDFLAGS}'"
  49. REMOVE_M32 = "sed -i -e 's/#define TARGET_CFLAGS_ARM_ON_X86_64.*/#define TARGET_CFLAGS_ARM_ON_X86_64\t\"TARGET_CFLAGS=-D_FILE_OFFSET_BITS=64\"/g' ${S}/configure.c"
  50. REMOVE_M32_class-cross = ""
  51. do_configure() {
  52. :
  53. }
  54. do_compile_prepend() {
  55. case ${TARGET_ARCH} in
  56. aarch64*) ARCH=ARM64 ;;
  57. arm*) ARCH=ARM ;;
  58. i*86*) ARCH=X86 ;;
  59. x86_64*) ARCH=X86_64 ;;
  60. powerpc64*) ARCH=PPC64 ;;
  61. powerpc*) ARCH=PPC ;;
  62. mips*) ARCH=MIPS ;;
  63. esac
  64. sed -i s/FORCE_DEFINE_ARCH/"${ARCH}"/g ${S}/configure.c
  65. ${REMOVE_M32}
  66. sed -i 's/>/>/g' ${S}/Makefile
  67. }
  68. do_compile() {
  69. oe_runmake ${EXTRA_OEMAKE} RECIPE_SYSROOT=${RECIPE_SYSROOT}
  70. }
  71. do_install_prepend () {
  72. install -d ${D}${bindir}
  73. install -d ${D}/${mandir}/man8
  74. install -d ${D}${includedir}/crash
  75. install -m 0644 ${S}/crash.8 ${D}/${mandir}/man8/
  76. install -m 0644 ${S}/defs.h ${D}${includedir}/crash
  77. }
  78. do_install_class-target () {
  79. oe_runmake DESTDIR=${D} install
  80. }
  81. do_install_class-native () {
  82. oe_runmake DESTDIR=${D}${STAGING_DIR_NATIVE} install
  83. }
  84. do_install_class-cross () {
  85. install -m 0755 ${S}/crash ${D}/${bindir}
  86. }
  87. RDEPENDS_${PN} += "liblzma"
  88. RDEPENDS_${PN}_class-native = ""
  89. RDEPENDS_${PN}_class-cross = ""
  90. # Causes gcc to get stuck and eat all available memory in qemuarm builds
  91. # jenkins 15161 100 12.5 10389596 10321284 ? R 11:40 28:17 /home/jenkins/oe/world/shr-core/tmp-glibc/sysroots/x86_64-linux/usr/libexec/arm-oe-linux-gnueabi/gcc/arm-oe-linux-gnueabi/4.9.2/cc1 -quiet -I . -I . -I ./common -I ./config -I ./../include/opcode -I ./../opcodes/.. -I ./../readline/.. -I ../bfd -I ./../bfd -I ./../include -I ../libdecnumber -I ./../libdecnumber -I ./gnulib/import -I build-gnulib/import -isysroot /home/jenkins/oe/world/shr-core/tmp-glibc/sysroots/qemuarm -MMD eval.d -MF .deps/eval.Tpo -MP -MT eval.o -D LOCALEDIR="/usr/local/share/locale" -D CRASH_MERGE -D HAVE_CONFIG_H -D TUI=1 eval.c -quiet -dumpbase eval.c -march=armv5te -mthumb -mthumb-interwork -mtls-dialect=gnu -auxbase-strip eval.o -g -O2 -Wall -Wpointer-arith -Wformat-nonliteral -Wno-pointer-sign -Wno-unused -Wunused-value -Wunused-function -Wno-switch -Wno-char-subscripts -Wmissing-prototypes -Wdeclaration-after-statement -Wempty-body -feliminate-unused-debug-types -o -
  92. ARM_INSTRUCTION_SET = "arm"
  93. # http://errors.yoctoproject.org/Errors/Details/186964/
  94. COMPATIBLE_HOST_libc-musl = 'null'