fakeroot_1.12.4.bb 748 B

1234567891011121314151617181920212223242526
  1. DESCRIPTION = "Gives a fake root environment"
  2. HOMEPAGE = "http://fakeroot.alioth.debian.org"
  3. SECTION = "base"
  4. LICENSE = "GPL"
  5. PR = "r2"
  6. SRC_URI = "\
  7. ${DEBIAN_MIRROR}/main/f/fakeroot/fakeroot_${PV}.tar.gz \
  8. file://configure-libtool.patch \
  9. "
  10. inherit autotools
  11. do_install_append() {
  12. install -d ${D}${includedir}/fakeroot
  13. install -m 644 *.h ${D}${includedir}/fakeroot
  14. install -d ${D}${libdir}/libfakeroot/
  15. oe_libinstall -so libfakeroot ${D}${libdir}/libfakeroot/
  16. }
  17. # fakeroot needs getopt which is provided by the util-linux package
  18. RDEPENDS_${PN} = "util-linux"
  19. SRC_URI[md5sum] = "aaefede2405a40c87438e7e833d69b70"
  20. SRC_URI[sha256sum] = "dbcab1f495b857e67feff882e018ca59958b8d189ff1f76684d28e35463ec29d"