dbus-c++-native_git.bb 403 B

1234567891011121314151617
  1. require dbus-c++_git.bb
  2. inherit native
  3. FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/dbus-c++"
  4. # actually dbus-native and expat-native, but even the bearest build machine should have that nowadays...
  5. DEPENDS = ""
  6. do_compile() {
  7. oe_runmake -C src libdbus-c++-1.la
  8. oe_runmake -C tools dbusxx-xml2cpp
  9. install -m 0755 tools/dbusxx-xml2cpp ${STAGING_BINDIR_NATIVE}
  10. }
  11. do_install() {
  12. :
  13. }