picocom_git.bb 697 B

12345678910111213141516171819202122232425
  1. SUMMARY = "Lightweight and minimal dumb-terminal emulation program"
  2. SECTION = "console/utils"
  3. LICENSE = "GPLv2+"
  4. HOMEPAGE = "https://github.com/npat-efault/picocom"
  5. LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=3000e4830620e310fe65c0eb69df9e8a"
  6. BASEPV = "3.1"
  7. PV = "${BASEPV}+git${SRCPV}"
  8. SRCREV = "90385aabe2b51f39fa130627d46b377569f82d4a"
  9. SRC_URI = "git://github.com/npat-efault/picocom \
  10. file://0001-Fix-building-with-musl.patch \
  11. "
  12. S = "${WORKDIR}/git"
  13. EXTRA_OEMAKE = "'CC=${CC}' 'LD=${CC}' 'VERSION=${BASEPV}' \
  14. 'CFLAGS=${CFLAGS}' 'LDFLAGS=${LDFLAGS}' "
  15. do_install () {
  16. install -d ${D}${bindir}
  17. install -m 0755 ${BPN} pcasc pcxm pcym pczm ${D}${bindir}/
  18. }