libbytesize_2.4.bb 826 B

123456789101112131415161718192021222324252627282930
  1. DESCRIPTION = "The goal of this project is to provide a tiny library that would \
  2. facilitate the common operations with sizes in bytes."
  3. HOMEPAGE = "https://github.com/rhinstaller/libbytesize"
  4. LICENSE = "LGPLv2+"
  5. SECTION = "devel/lib"
  6. LIC_FILES_CHKSUM = "file://LICENSE;md5=c07cb499d259452f324bb90c3067d85c"
  7. S = "${WORKDIR}/git"
  8. B = "${S}"
  9. SRCREV = "732ee8d28492e4bc9b52c29bcb81a5c19388d002"
  10. SRC_URI = "git://github.com/rhinstaller/libbytesize;branch=master"
  11. inherit gettext autotools python3native
  12. DEPENDS += " \
  13. libpcre2 \
  14. gmp \
  15. mpfr \
  16. gettext-native \
  17. "
  18. FILES_${PN} += "${PYTHON_SITEPACKAGES_DIR}/bytesize"
  19. PACKAGECONFIG ??= "python3"
  20. PACKAGECONFIG[python3] = "--with-python3, --without-python3,,python3-core"
  21. EXTRA_OECONF = "--without-gtk-doc"
  22. EXTRA_OEMAKE = "py3libdir=${PYTHON_SITEPACKAGES_DIR}"