initramfs-debug-image.bb 636 B

1234567891011121314151617181920
  1. # Simple initramfs image. Mostly used for live images.
  2. DESCRIPTION = "Small image capable of booting a device. The kernel includes \
  3. the Minimal RAM-based Initial Root Filesystem (initramfs), which one can use \
  4. to check the hardware efficiently."
  5. PACKAGE_INSTALL = "initramfs-debug busybox base-passwd ${ROOTFS_BOOTSTRAP_INSTALL}"
  6. # Do not pollute the initrd image with rootfs features
  7. IMAGE_FEATURES = ""
  8. export IMAGE_BASENAME = "initramfs-debug-image"
  9. IMAGE_LINGUAS = ""
  10. IMAGE_FSTYPES = "${INITRAMFS_FSTYPES}"
  11. inherit core-image
  12. IMAGE_ROOTFS_SIZE = "8192"
  13. IMAGE_ROOTFS_EXTRA_SPACE = "0"
  14. BAD_RECOMMENDATIONS += "busybox-syslog"