gnulib_2018-03-07.03.bb 1.1 KB

12345678910111213141516171819202122232425262728293031323334353637383940
  1. SUMMARY = "The GNU portability library"
  2. DESCRIPTION = "A collection of software subroutines which are designed to \
  3. be usable on many operating systems. The goal of the project \
  4. is to make it easy for free software authors to make their \
  5. software run on many operating systems. Since source is designed \
  6. to be copied from gnulib, it is not a library per-se, as much \
  7. as a collection of portable idioms to be used in other projects."
  8. HOMEPAGE = "http://www.gnu.org/software/gnulib/"
  9. SECTION = "devel"
  10. LICENSE = "LGPLv2+"
  11. LIC_FILES_CHKSUM = "file://COPYING;md5=56a22a6e5bcce45e2c8ac184f81412b5"
  12. SRCREV = "0d6e3307bbdb8df4d56043d5f373eeeffe4cbef3"
  13. SRC_URI = "git://git.sv.gnu.org/gnulib.git \
  14. "
  15. S = "${WORKDIR}/git"
  16. inherit utils
  17. do_install () {
  18. cd ${S}
  19. check_git_config
  20. git checkout master
  21. git clone ${S} ${D}/${datadir}/gnulib
  22. }
  23. do_patch[noexec] = "1"
  24. do_configure[noexec] = "1"
  25. do_compile[noexec] = "1"
  26. do_package[noexec] = "1"
  27. do_packagedata[noexec] = "1"
  28. deltask package_write_ipk
  29. deltask package_write_deb
  30. deltask package_write_rpm
  31. deltask do_deploy_archives
  32. BBCLASSEXTEND = "native"