tiptop_2.3.1.bb 1.3 KB

12345678910111213141516171819202122232425262728293031
  1. SUMMARY = "Hardware performance monitoring counters"
  2. HOMEPAGE = "http://tiptop.gforge.inria.fr/"
  3. LICENSE = "GPLv2"
  4. LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
  5. DEPENDS = "ncurses libxml2 bison-native flex-native"
  6. SRC_URI = "http://tiptop.gforge.inria.fr/releases/${BP}.tar.gz \
  7. file://0001-Fix-parallel-build-problems-by-Adrian-Bunk.patch \
  8. file://0002-fix-reproducibility-of-build-process.patch \
  9. file://0001-Fix-build-when-S-B.patch \
  10. "
  11. SRC_URI[md5sum] = "46ca0fdf0236f02dd2b96d347626d2a2"
  12. SRC_URI[sha256sum] = "51c4449c95bba34f16b429729c2f58431490665d8093efaa8643b2e1d1084182"
  13. inherit autotools
  14. EXTRA_OECONF = "CFLAGS="$CFLAGS -I${STAGING_INCDIR}/libxml2""
  15. COMPATIBLE_HOST = "(i.86|x86_64|arm|powerpc|aarch64).*-linux"
  16. do_configure_prepend () {
  17. # Two bugs in configure.ac when cross-compiling.
  18. # 1. The path of libxml2. Specify it in EXTRA_OECONF.
  19. # 2. hw's value on other platforms. Replace it if the target is
  20. # not i*86/x86_64.
  21. if ( echo "${TARGET_ARCH}" | grep -q -e 'i.86' -e 'x86_64' ); then
  22. sed -i 's= -I/usr/include/libxml2==' ${S}/configure.ac
  23. else
  24. sed -i 's/hw=`uname -m`/hw="unknown"/' ${S}/configure.ac
  25. sed -i 's= -I/usr/include/libxml2==' ${S}/configure.ac
  26. fi
  27. }