packagegroup-fonts-truetype.bb 726 B

12345678910111213141516171819202122232425262728293031323334353637383940
  1. SUMMARY = "Install one of these tasks to get support for truetype fonts"
  2. SECTION = "fonts"
  3. LICENSE = "MIT"
  4. LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
  5. PV = "1.0"
  6. PR = "r2"
  7. inherit packagegroup
  8. PACKAGES += "\
  9. ${PN}-core \
  10. ${PN}-chinese \
  11. ${PN}-japanese \
  12. "
  13. RRECOMMENDS_${PN} = "\
  14. ${PN}-core \
  15. ${PN}-chinese \
  16. ${PN}-japanese \
  17. "
  18. RDEPENDS_${PN}-core = "\
  19. fontconfig-utils \
  20. \
  21. ttf-dejavu-common \
  22. ttf-dejavu-sans \
  23. ttf-dejavu-sans-mono \
  24. "
  25. # ttf-dejavu-serif
  26. RDEPENDS_${PN}-chinese = "\
  27. ${PN}-core \
  28. ttf-arphic-uming \
  29. "
  30. RDEPENDS_${PN}-japanese = "\
  31. ${PN}-core \
  32. ttf-sazanami-gothic \
  33. ttf-sazanami-mincho \
  34. "